•Plug ‘n’ play support for USB devices on Windows

•Plug ‘n’ play support for USB devices on Windows
What does this do?

This means that you can plug USB device while C9 is running, and it will be recognized? No need to restart Cubase anymore after plugging USB device?

Yes :slight_smile:

Yes, finally!! :astonished: :smiley:
This alone is a reason for the update!

Confirmed to be working for keyboards. USB unplugged during a project session. Then plugged back in and Cubase finds it and it works perfectly. No interaction with Cubase required.

Nice work on this one. SERIOUSLY! :slight_smile:

Regards :sunglasses:

While the feature is nice and should have been implemented by default, I believe it is not crucial:

professionals typically have their devices (e.g. a MIDI keyboard) connected permanently, others can easily connect before starting the DAW.

To be clear, I don’t consider the feature unneeded, there are just much more important features that are still not implemented.

That’s right if you need this feature your not a professional :slight_smile:

Seriously though, Mac has done this for years and it was one of the many benefits and seriously handy.

For what it’s worth, I’m a hobbyist, and I need HiDPI support much more.

Maybe not “crucial” but enough users thought it should be incorporated and now it has been. Nice :wink:

BTW… “Professionals” are not the only ones who typically have their devices connected permanently. But I’m sure that even a professional running Cubase on a PC will appreciate the fact that they can now plug in a USB device (or reconnect it in if it got disconnected) and Cubase will recognize it without having to restart CB.

Regards :sunglasses:

Sometimes USB devices need rebooting or loose connection with the host. Now it is possible to restart the device without restarting Cubase. I would say it is a rather professional feature.

There’s some more info about this in a knowledgebase FAQ, which states it “works reliably for MIDI devices running on the “Windows MIDI” protocol. That’s why the “Direct Music” protocol for MIDI is disabled by default.”

That is a bit of a silly comment. I make my living off of my productions exclusively. I am a well educated professional. I NEEDED that function and appreciate finally having it.

Can i just say that this is TOTALLY AWESOME!!!
I’ve been waiting for this like forever.
All the times I started Cubase and forgot to turn my (name 20 random usb synths) on.

Indeed, it seems so basic but absolutely wonderful if like me you forget to turn the one you just happened to need on before launching Cubase!


Anyone using a laptop will appreciate this. Not uncommon for a user of any category to open up a project to do one thing and then decide that they need to connect a USB controller. Having to restart Cubase was a major pain in the ass.
Desktop users have the luxury of being able to leave their devices permanently connected

+1 Great addition and a super timesaver!

Exactly ! From Hans Zimmer to the guy with $50 gadget synths will appreciate this, I often forget also , trust me I am no amature…

For live stage use it must be a relief,.

My devices are permanently connected, but not necessarily switched on, when I boot up Cubase.

I don’t leave powered devices on, when not in use.

No doubt this feature is a big timesaver, but I’ve found a little drawback: now, if you open a project that used tracks assigned to an specific MIDI USB device, but which is not switched on at the moment of loading, you will get a pop up window asking you to reassign the device. And this happens with EVERY project you open. So you are kind of obliged to switch the device on anyway, specially if you are jumping between projects and don’t want that window to show.

Mmm… Interesting. Is there a way that you can set your track(s) input device(s) as “All Midi Inputs”?

I say this because I don’t have this issue with my old (circa 1990) trusty PSR38 keyboard. But it is connected as “All Midi Inputs”. And on the few projects I have working in CB9 I have no tracks assigned to a specific USB device.

I tried this test…
With the PSR38 totally disconnected, I start Cubase. Then open a project where I previously recorded a few instrument tracks with the PSR38. I don’t get any warnings. Then I plug the PSR38 USB connection in, turn it on, set it to local off, and BOOM… it works perfectly. I can record on any new or existing instrument track. Like I said, this is when the track inputs are set to “All Midi Inputs”.

Regards :sunglasses: