Plugin not recognized...

I am building two VST plugins for Cubase. The VST SDK is 3.6.13, Cubase is 7.5.64.

I’m using Visual Studio 2019, up to date (16.4.3).

Both plugins compile and link successfully. Both plugins have unique GUIDs generated by Both plugins are 64 bit. They build successfully in both DEBUG and RELEASE configurations.

Just to be clear, here are the GUIDs:

plugin #1:
static const FUID DMXMidiProcessorUID(0x1C530930, 0xAC8A4913, 0x988B642D, 0x246BF5F1);
static const FUID DMXMidiControllerUID(0x71A1D91D, 0x065A4B60, 0x9E57266D, 0xAF69BA52);

plugin #2
static const FUID CameraProcessorUID(0x41E3A6A2, 0xC1991743, 0xA64945DC, 0x3FB7D51D);
static const FUID CameraControllerUID(0xFAF056D1, 0x245C8945, 0x916485C6, 0x714C768F);

The first plugin is recognized by Cubase (and VSTPluginTestHost). The second plugin is NOT recognized. I have tried everything I know to determine why the second plugin might be missed. It’s NOT blacklisted. I have even tried deleting the “C:\Users\Brian\AppData\Roaming\Steinberg\Cubase 7.5_64” directory and regenerating it by relaunching Cubase. No difference, same problem.

Considering that the first plugin executes correctly at run-time, and the second plugin was modeled after the first, it’s a complete mystery to me why the second plugin is not recognized. I don’t expect a specific answer to this problem, but would welcome any suggestions regarding WHERE ELSE I might investigate. I’m out of ideas.


does the validator loads your plug-in?