Plugins not loading properly in Cubase 10.5


I’m having issues with Plugins loading in Cubase 10.5 . I’m having problems loading both Fabfiler and Arturia Instruments (my Cubase and UA plugins are working fine).

Here are the symptoms:

  1. Fabfilter plugin loads, but the graphical interface takes 7-10 seconds to show, or does not show at all. The Pro line of Fabfilter seems to be the worst.
  2. Fabflilter loads but graphic user interface renders smaller within plugin frame (i.e., 1/4 the size as opposed to filling the entire frame)
  3. Arturia - moving the instrument window causes the interface to flicker or get smaller in size.

This issue occurred after updating to 10.5

I’m using my MacBook Pro and an external monitor (2 monitor setup)

Any ideas would be much appreciated.

Glad to hear I’m not alone. Battery is acting all funky and continues to play even after hitting the stop button. I wish I had some answers for you but my solution is to move back to Cubase 10.

Weird – I haven’t tried Battery yet. I’m surprised we haven’t heard more at this point. Huge pain with workflow – are all of your plugins working?

I did a fresh install of Windows and took the approach of installing things as needed. So far I’ve only tested Kontakt, Battery, and Nexus. I have Komplete 11 by NI and all of those pluigns are installed (but not tested). I got a serious crash when I tried to load Komplete Kontrol. I haven’t installed Fab Filter yet (I don’t think I will). Melodyne was causing some major issues in Cubase 10. I pretty much had to uninstall it and only fire it up when I needed it. I set my projects to back up automatically every 3 minutes in case of a “serious error”.

But so far… Battery is the only one that’s caused an issue. It’s a legit copy too so nothing weird about it.

I will update as I progress but after I’m done with this current project I am going to bounce the tracks and then install Cubase 10.