Plugins stuck in Generic view -- and no "Switch to Plugin Editor" menu item

I wouldn’t re install yet. Try starting cubase with completely new settings. Go to C:\Users<your user name>\AppData\Roaming\Steinberg\ and temporarily move all the “Cubase xx” folders in there to a different location, say your desktop (you can move them back after testing).
Now start Cubase, which will initialize with completely fresh settings and see whether that makes a difference.
If that doesn’t do anything, then yeah, could be something graphic card related…
Very weird though that the item in your plugin menu is missing.

Thanks, Jan Felix
Tried your fix but it didn’t I’m afraid!
Thanks, anyway.

I feel that this is an issue that a member of the official Steinberg support staff should pick up on and discuss with the appropriate developer(s) how this menu entry can possibly disappear.
And why all Steinberg GUIs got switched.

Because the needed graphics framework isn’t available?
There was a new version introduced on 12 for the hardware accelerated graphics for the GUI.

But I still have no solution.

1 Like

@Bazza100 did not indicate whether the non-generic GUIs were available with Cubase 12 before the issue appeared. Maybe they can do that now.

Hi Johnny - yes Waves, various other 3rd party VST stuff was and is working fine! Only the Steinberg stuff seems affected (that still works, by the way - just difficult to use with reduced visibility).
Here’s a thought, though… I’m running this with a single screen, therefore it’s a constant competition between Start/Stop on the transport bar and run Word or Excel when you overshoot! I’ve frozen the task bar and reduced the screen size. Could this possibly have some relation to the reduced menu and fixed, low res VST display?? (I know it shouldn’t… but this IS Cubase and this IS WINDOWS!!)

When you say “reduced the screen size”, did you mean the resolution of your display? Cubase has a requirement of 1440*900 pixel resolution. Can you make sure that your system has that?

No just reduced the size of the Cubase’s screen to fit whole screen less task bar area.

That’s 1920 by about 900 pixels

We still wait to get the specs of your system.

Sorry Steffen for the delay! I am running Cubase Pro 12 ver. 12.0.60
under Windows 11 v22H2 64bit on a Dell Inspiron 15
With Intel i5-8250u CPU @1,60 GHz with 16GBytes RAM
Along with Cubase I have various Waves and other Vst’s and, with this set-up I am
using a Focusrite 2i4 interface. All of which works just fine except for the graphics anomaly
with the Steinberg VST’s

Is the Intel graphics driver installed and up to date?
This very old CPU isn’t the best solution for a DAW.

It is getting a bit long in the tooth but I’m only replaying a max of 10 tracks audio (48K 24bit) and 3 or 4 Midi tracks. And it’s been fine with the exact same load and fx, etc., until recently. So yes, I agree it’s not the slickest of machines but I’m still fairly convinced that the problem lies in a (mis-)setting somewhere!!

And drivers are up-to-date.

I’m not aware of a setting that switches all plugins to the generic editor.
There are possible incompatibilities that deactivate features required for the GUI.


Can you please explain IN DETAIL what you mean with “the Cubase screen”? Maybe underly it with a screenshot? You are welcome to come to the forum directly instead of using email. That might make it easier.

Hi Johnny. Taskbar is fixed size (no pop-up) at bottom of screen. Cubase window is dragged to fit. This has generally been standard set-up for some time and no problems before this.

The weird thong is, if you compare the screenshots from steve and bazza100, that they look quite different. While steve’s menu has the well known “switch to plugin editor” entry, separated by a divider line, in bazza’s screenshot that line is missing and we get an entry “allow window tobe resized”, which I’ve never seen before, but maybe that is because I don’t use generic view that often…
This makes me believe that the menu is build like that on purpose, like “if system does not have OpenGL version x.y then disable the menu entry”.
If that is really the case, I would expect some kind of global error message for the user, though, like “your system doesn’t have x.y, we cannot display our plugins”.

As an aside, I don’t know whether Cubase plugins use OpenGL, I just used that as an example, because once in a while you read of a plugin that uses OpenGL and on some older system it doesn’t work, e.g. just displays a black window. Usually the developer offers some kind of configuration to switch to software rendering, though.

But that is all speculation, I admit I have no idea what is going on here…

Thanks for posting the screenshot.
Is your display scaled to 125% or higher? If so, could you try to scale it to 100% and check if that changes the menu of the plugins?