Poll for stability of C11.0.10 on PC , update from C11 or not?

Cubase Pro 11.0 has been really stable for me from day 1 running Windows 10 (1909).

Nonetheless, I made the early jump to 11.0.10 on the day it came out.

However since then, I’ve had a couple of very weird things happening to my Cubase installation.

I can’t tell yet, if these are more Cubase problems or more Windows problems:

  • An eLicenser problem complaining about deactivated licenses, first for some HALion Sonic content, which then “migrated” to the same error message but for Groove Agent 4 content. - Neither made sense, since deleting the instrument track and re-adding the same VSTi with the same sound loaded worked fine without eLicenser complaints. But saving that now working fine project and then re-opening it right away, triggered the eLicenser complaint again.

  • Opening a .cpr Cubase project file from the Explorer, all of a sudden opened in Cubase 9.5 rather than Cubase 11. Re-installing Cubase 11.0.10 didn’t make a difference. The Windows default program for .cpr files was set and I set it again to Cubase 11. Didn’t help. So I uninstalled Cubase 9.5 and then the .cpr files opened in Cubase 9. Right clicking on a .cpr file and choosing Cubase 11 to open with, still ended up choosing the older Cubase version. And interestingly enough, the icons for Cubase on .cpr files also had disappeared (replaced by generic file icons) from the Explorer window when Cubase 11 was selected as the default app for file extension. cpr.
    When I changed the default app for .cpr files to an older version of Cubase, the Cubase icons immediately showed up in the Explorer file listings for those files. Changing the default back to Cubase 11 brought back the generic icons. - I ended up uninstalling all of the Cubase versions older than Cubase 10 (I had about 5 older versions still on my system). Then the icons came back and double-clicking on the files opened Cubase 11 ok again.

Like I mentioned up top, I’m not certain that this was a Cubase 11.0.10 problem - could have been something screwed up in the Windows registry on my machine. So I’m not putting this into the Issues forum.

If I get many more mystery errors, I may downgrade to see if it makes a difference. But for now, I plan on staying on Cubase 11.0.10. If that changes I’ll try to remember to post in this thread.