"Pop-up Toolbox on Right Click" broken.(Solved)

The “Pop-up Toolbox on Right Click” preference appears to be broken. At least it does on a Mac running C10.0.0.5 on Sierra.

First problem is the checkbox has to be unchecked before the toolbox appears with a right click. This is backwards.

The second problem is that once a tool has been selected, it is impossible to re-select any other tool with a right click. I could show this with a screen grab if necessary. It is quite repeatable.

The only solution is to recheck the “Pop-up Toolbox on Right Click” option to dismiss the function entirely and use the menubar Tools selector or individual Tool type key commands.


Could you please attach the screen grab?

Martin: Here’s an annotated screen capture of the problem. I should note that This happens even if C10’s Preferences are trashed and it rebuilds new ones on relaunch. No matter what, once the Toolbar on Right Click is invoked, it will never permit reselection of the Select Tool on it’s own. And there is that problem of the backwards behavior of the Preferences checkbox.

Link to capture removed by OP


I tested on my side and it works different way. Could you try in Cubase Safe Start Mode, please?

  1. The Pop-up Toolbox on Right-Click works as expected on my side.

  2. When I right-click, I can choose any tool. If I want to switch from Normal Sizing to the Sizing Applies Time Stretch after the right-click, I have to hold-down the right-click and click with the left button to get the dropdown menu.

I can confirm the behaviour Weasel described. If you have chosen scissors, like Weasel did in the video, it’s impossible to choose the Select Object Tool, because when you hover with the mouse over the Select Object Tool its Drop Down menue appears immidiately. It prevents you from choosing the Icon of Select Object Tool itself.
So it’s not about choosing the tool from the tool box per se, but about choosing the Select Object Tool after you’ve chosen another tool.


Don’t click on the tool, just select it, and release the right-button.

Does it work to you?

Yes for all tools, EXCEPT Object Selection Tool. Sometimes by holding CTRL Drop Down Menu of Object Selection Tool opens automaticaly even without hovering over the icon itself. Then you are not able to select anything. It is if Drop Down Menu Layer has the priority over Tool Box Layer. Even if you change one of the Drop Down Menu Options, you are still not able to select the selection tool.

By the way, it happens with all the Tools from the Toolbox, which have a drop down menue - Timewarp, Line and Listen.

Sorry, I still can’t really reproduce it here on macOS 10.13 and Windows 10.

Try this.
You have your tool box on the right-click (“Pop-up Toolbox on Right Click”-is ticked). Hover over the tool icon (let’s say Timewarp) while holding the right-click. When you press left-click while hovering over Timewarp, still holding rightclick, the timewarp-Icon turns frist green then yellow then the dropdown menue of timewarp-tools opens. That’s how it should work. When you click CNTRL in this scenario the case sensetive dropdown menue appears.
When unticking “Pop-up Toolbox on Right Click” you should have the inverted scenario. Right Click - case sensetive dropdown menue. CNRL+Righ Click-Tool Box. The principle how Toolbox selection works should be the same. But it’s not. In this case Toolbox behaves differently for dropdown menues. It doesn’t turns green then yellow. Drop Down Menue appears while hovering over tools and I suppose it’s not how it should’ve been.

Slight twist to all this…

Once you have opened a tool’s sub-menu (holding right-click, hovering with mouse, left clicking), but you DON’T choose anything there - you know, like you changed your mind - you cannot now try selecting any other tool. Instead, you have to release the toolbox completely and start again your whole choosing-next-tool procedure.

Could you try in Cubase Safe Start Mode, please?


Good call on Safe Mode. Once in Safe Mode, the Preference menu item checkbox behaved as expected and the functionality of the toolbar popup menu acted “normally”. And by “normally”, I mean that all tools are selectable _excep_t for the dropdown selections of Object Selection, Time Warp, Line and Play. These are only available via the Project Toolbar/Tool Buttons selector. It has worked this way as far back as C7, at least… so I consider this “normal”. I am now wondering why the right click toolbar does not exactly mirror the same functionality as the Toolbar/Tool Buttons selector. But that is a different issue. Or feature request.

After some exploration, I discovered that my 3rd party USB Overdrive mouse driver was out of date. Replacing that, restored proper Right Click Toolbar functionality. My advice to any Mac (and possibly PC) users experiencing this problem is to check and update any 3rd party mouse related drivers. Over here, on a Mac, a new driver fixed it.

Who decided the problem is solved? :open_mouth:

I finally found exactly how it happens. Latest Windows 10 Pro. It’s not a mouse/driver problem.

with “Pop-up Toolbox on Right Click” OFF, the Object Selection Tool IS THE ONLY ONE WHICH REQUIRES YOU TO RELEASE THE MODIFIER KEY BEFORE THE MOUSE BUTTON in order to get activated from the cursor toolbox. Since I also sometimes work with “Pop-up Toolbox on Right Click” activated, I always release the mouse button first, as a habit. There is no reason to make an exception for just the one Object Selection Tool. It certainly looks like a bug.

Similar backwards step on the Mac version. I now have to move my cursor way further in a thin area to select a tool, whereas before I could resize the toolbox to be 3 rows of 4 and not 1 row of 12. It’s seriously interfered with my workflow. And I’ve been using Cubase professionally since it was on Atari…

Who on earth thought it was a good idea to remove a function that’s clearly so useful???

Probably the same twisted mind that thought doing this to the Transport Panel (F2) was a good idea …

Yes indeed. I don’t use a floating transport so that doesn’t affect me, but it’s another example of Steinberg fiddling with something that wasn’t broken. I’m sure there are probably others too.

There are some great innovations in 10 like the audio pitch editing, but if they want to change something you’d hope they’d give us an option… very disappointing.

There are always complaints from users following every release, it’s something you get used to, and with most things, it’s a matter of adapting how you use the product. Pretty soon the complaints die down and eventually everyone descends into a reasonably happy, if sometimes grumbling, state of contentment. Any discomfort is almost always mitigated by other improvements or new features that one comes to appreciate over time.

This is how Steinberg has managed to maintain such a loyal customer base over so many years (OK, let’s not talk about Cubase 4 …).

I think we can all accept that not everything can have multiple options but the problem for long-time users this time around is that two of the most fundamental features of Cubase, the right-click Toolbox and the floating Transport Panel that have been there since the Atari days were changed for no discernable reason.

It’s as if some junior designer at Daimler decided that the three-pointed star thing on the bonnet of the Mercedes-Benz looked a bit jaded … :unamused:

Yes indeed. I’d just like to know why such a long serving and seemingly harmless feature has needed to be removed. Judging by the reactions it looks like nobody was asked before the decision was made…sadly not the first time things like this have happened.
We used to have audio parts that could overlap and still work without cutting out provided the segments inside them didn’t overlap, but that was removed even though it meant the behaviour of audio parts was then different from midi tracks. So much for consistency…

-1 :frowning:

The 9.5 Transport Bar (F2) was concise, pro-looking, fit well in all the editors, had more functions, was a central part of my workflow in Cubase. This “new” ribbon thing is much less pro-looking and has reduced functionality. I said in a previous post that I didn’t use F2 Transport bar much, but I was wrong. I use it much more than I even realized, only noticing just how much I used it with the annoying, ugly, non-pro-looking, hobbyist-looking reduced functionality transport ribbon thing. This update feels, frankly, like a rip off.

(Also, to stray from the topic. While the new side chain set-up system is a real improvement, on the Strip Rack, the Side Chain button is GONE and there’s not even an indicator that a channel has a side chain in place. There’s no way to open graphic editors for Channel Strip items that have such from the Rack – must be a “pro” feature I have to acclimate to?)

I really hope this all gets repaired. If I hear someone say “known issue” one more time…

Ummmm… why is this topic title called “(Solved)” ?? I suddenly got excited and thought is was fixed…