Popping when switching out of Dorico

I am having an issue where every time I remove focus from Dorico (I am switching back and forth from youtube for a transcription) There is a semi-loud double pop that happens in my headphones (or speakers if I am using them). This is accompanied by some latency when trying to start the video again while the audio engine switches back to allow input from the browser (I assume). I am using a Behringer UMC 1820 interface for my sound input and output (although my midi keyboard is usb), and I’m on Windows 10.

I unchecked the option that allows “applications to take exclusive control over this device” in my sound settings (this doesn’t seem to prevent Dorico from taking exclusive control over my sound device) and I also checked “suspend audio device in background” in Dorico preferences. My audio device’s control panel does not have an option to disable exclusive control. This is frustrating because I would like to be able to play sound in Dorico at the same time as Youtube, but they seem to be mutually exclusive.

I don’t know the Behringer device, but I know that that, what you want to achieve (Dorico/YouTube producing sound at the same time), is possible even with the preference “suspend audio device in background” unchecked. So what does happen if you uncheck it again?

When I uncheck it, I am simply unable to play any sound outside of Dorico. When I re-check it, I am able to play other sounds, but the popping comes back.

Edit: I have different output channels associated with my interface so I tried sending Dorico’s output to 1-2 and the rest of my computer’s to 3-4, but that didn’t work. Similarly, I tried assigning both outputs to my regular computer sound card but that didn’t work either.

Does the Behringer have an own dedicated ASIO-driver or are you using it in conjunction with the Generic Low Latency driver?
When using the Generic Low Latency driver and opening the driver’s Control Panel, does it show the Behringer as valid output ports?

I am using Behringer’s driver. When I go to device setup I select “UMC ASIO driver”, which gives the options of 1-2, 3-4, etc because it currently has 10 outputs. I tried using ASIO4ALL and routing the Behringer’s signal through it but that caused nonstop popping and no sound.

I get an issue like this (not necessarily with Dorico, but on my computer in general) when different programs want to run at different sample rates and I switch between them. I’m on a Focusrite Scarlett, but the principal might still apply.

For me, the fix is to make sure that, as Ulf is maybe suggesting, that Dorico is using the same audio device drivers as the rest of the computer, but also that the sample rate is the same between the two as well (I try to keep the buffer size the same also, but I don’t know if this has any effect on it). Thus, my interface has no need to switch settings when changing focus between programs, and subsequently no pops or chugging, etc.

Good luck!

This worked! Thank you so much, this has been bothering me for a long time!

For reference: On Windows 10, I went to Sound Settings -> Sound Control Panel -> Properties of my interface’s output -> Advanced and changed it to the 48000 Hz setting.

Glad to hear it! Welcome to the forum and Happy Dorico-ing!