“Port Open Error” when Adding more than one Rack XS VSTi to a Cubase Elements 10.5 Project

Hi All

I hope everyone is well and staying safe!

I’ve dusted off my Yamaha Motif Rack XS and taken advantage of Steinberg’s Cubase Elements 10.5 free 60 day trial to help with my social distancing. Almost everything is working great and I’m surprised at how quickly I’m getting back into the swing of things. I do have one niggle that I haven’t been able to resolve (although I do have a workaround so it’s no big deal). Would be nice to have a proper solution though, so I thought I’d re-connect with the forum in the hope that someone could point me in the right direction…

I’m using the Rack XS as a VST instrument in Cubase Elements 10.5.12 under Windows 10. I have version 1.6.8 of the Rack XS Standalone/VST Editor, the Yamaha USB-MIDI Driver V3.1.4 and am using the Steinberg UR22MKII audio interface.

I can add one “instance” of the Rack XS VSTi as an instrument track in Cubase with no problems at all. The Rack XS Editor fires up and is on-line and synchronised with the Rack XS. I can choose a patch to use on the track and change this at will, either through the Rack XS Editor or the VSTi controls in the Cubase VST Instrument panel. So far so good. However, when I add another track, another “instance” of the Rack XS editor fires up but this time there is a “Port Open Error” in red mid-way down the Rack XS Editor window (even if I close the previous “instance” associated with the first track I added). The error disappears after a few seconds, but the editor is “offline” and while patches can be selected, they are not transmitted to the Rack XS or Cubase.

Reading the Release Notes for the Rack XS Editor it says “Editor may launch in the OFFLINE status or “Port Open Error” may appear when you: 1) select the MOTIF-RACK XS Voice via the Media Bay, 2) create the Instrument Track on Cubase, and 3) start the Editor. Even if such a situation occurs, you can use the Editor by clicking the ONLINE/OFFLINE switch to set the status to ONLINE.”
In my case, clicking the ONLINE/OFFLINE switch just goes to the synchronisation window and displays the same “Port Open Error” message.

My workaround is to use the first “instance” of the Rack XS editor (in multi-mode) to change the patches and settings of all the other Rack XS VSTi tracks in the project. This is obviously not ideal, and it would be great if anyone out there has any suggestions as to how I can add more than one Rack XS VSTi instrument to a Cubase track without getting the Port Open Error. Fingers crossed it’s just me doing something silly (as usual)…

Many thanks in advance.

KKarl