position of tie and note spacing

if you look at the attached image, you can see, that the tie between the two bars is not positioned very pleasing (at least to my eyes). For my taste, the start of the tie is too far to the right and Dorico is leaving to much space between the notes and the barline. I could adjust this manually, but there are quite a lot of the collisions in this piece. Therefore I would like to ask, if there a setting (or two or three …), which can help me to adjust this automatically.
tie_note spacing.PNG

That big space before the barline looks suspicious. Is this an XML import, by any chance?

Yes it is (from Finale), but I did all reset options after import.

If you invoke the caret at the beginning of the a tied, isn’t there an “extra” 1/8 vertical bar appearing ? I had that sort of rhythmic oddity when importing from XML. If that happens, put the caret on that extra 1/8 gap, press shift-b, and add | (single barline) in the popover. This would create a 1/8 rest bar. Select it, shift-b and -1 in the popover and everything is in place again.

Thanks, MarcLarcher. I’ve just checked and there is no extra 1/8 note in the bar.

I did not mean an extra 1/8 note, but an extra orange line when the caret is on (the rhythmical grid that displays above the staff), but I’m sure you understood that.

Sorry for my bad English. Yes, I meant that there is no extra orange line (of a value of an eight note). I also changed the grid resolution and in every resolution there is only the expected number of lines.

I seems like both situations bring in some extra space: the collision avoidance of the flag with the tie and the the vertical alignment of the second voice and that doesn’t combine well.