Possible Bug: MIDI Recording


I think I encountered a bug when MIDI recording. I’m doing a solo piano piece that had a coda. When I try to record after the coda it jumps way back in the piece instead of the desired measure. I’m also not able to make Dorico jump to the Coda, but that may be a problem on my end.

Below is the attached file. Trying to MIDI record on m.105 and it jumps back to m.57


Those Who Fight.zip (458 KB)

Turn off “Play repeats” in Playback Options while you’re recording.


That works for now, but seems to be a bug either way.

Do I need to setup something so that Dorico jumps to the coda on the correct repeat?

That’s correct, and the Dorico developers already know about it. For now the workround is switch of “play repeats” when you want to record, as Dan already said.

It looks like you have to write “D.S. al coda” rather than only “D.S.” to make it jump to coda.