Possible copy/paste glitch with tuplets?

Total Musician Pedagogy.dorico.zip (499.6 KB)
When I try to copy all the notes from the treble staff of bars 4-7 and paste them to the bass staff (I select/copy all the notes, then select the bar rest on the bass-staff bar 4 and hit cmd-v), all the pasted triplet eighth-notes after the first three get transformed into regular eighths… Does this happen when you do it?
If not, what am I doing wrong?

Turn the signposts on and make sure they get selected as well with the notes. Dorico only copies what is displayed. It’s a known behavior (and an expected one, until now).

That’s a royal nuisance, btw. IOW I would still call this a glitch for all intents & purposes.
One shouldn’t have to constantly have the signposts visible in order to copy/paste, especially since the exact same action is being taken (selection just of the notes–not of the actual signposts).
Visible signposts clutters up the page too much.

Unclear what’s happening with your situation but if I select a string of triplets and make sure I’ve selected the number that corresponds to the triplet as well, I can copy and past without having to reveal any signposts. Sometimes the easiest way to accomplish this is with the system track, since it will select everything in the measure.
Screen Shot 2021-07-05 at 5.55.16 PM

Thing is, I’ve set Engraver option to just make the first triplet visible in a repeating series.

Moreover, when I delete a passage of repeated triplets and forget to make visible the triplet signposts, then the notes disappear but the triplet signposts don’t–even more of a nuisance.

In that case the only way without showing signposts is to select the music using the system track and then copy the result.