Possible major bug on Midi Transpose

Hi everyone, I’ve recently upgraded to CUBASE 13 pro, on PC running Windows 11 pro.

I’ve been using Cubase for over 25 years, and the feature that I’m having issues with in 13 is Midi Transpose in the key editor. Please let me explain the problem.
I wrote a new song on Piano, using my Ravenscroft Piano plug in. It’s an
intricate piano part, in Gm. When I started lead vocals, I decided the song was too low for my vocal, so I transposed the Piano up one semitone, to A Flat minor to accommodate my vocal range. As the song progressed, I wanted to make minor changes to the piano part in the Key editor. However, when I try to edit a note, I’m hearing the note in the original key of GM, Not A flat minor. It plays back in A flat minor, but if I select a note, it’s plays it in Gm. This makes editing the piano part almost impossible, as the bass, strings and pads are all in the new key of A flat minor.

I’ve looked for a setting thinking it might just be me, not understanding how the new key editor works, but I can’t see anything ? In older versions of Cubase, if you transpose a part, it’s always transposed in the key editor, automatically, but NOT in version 13.
As I say, I don’t know if this is a bug…or just a setting I’m missing?
Cheers Darren

HOW did you transpose? I am asking because there are around half a dozend ways to transpose something in Cubase.

And some of them change the underlying MIDI Data, while others modify the data on the fly during playback. It sounds like you are using a method that does the latter - probably by Transposing a MIDI Part via the Info Line, or using MIDI Modifiers in the Inspector.

Hi Johnny, hi Raino, yes I used the mid modifier section, which was new to me. On my last version of Cubase Transpose was always just on the left channel strip, easy to see and use.

So I guess ive used the wrong method. So in order to solve my problem, how would you transpose? Where have I gone wrong?

It use to be so simple! Seems to me there have been a lot of unnecessary changes, for no reason.
Thanks Darren

Hi Darren!

What version was this?

Lets call this the Inspector as to not confuse it with the Channel Tab to the left in the Project Window (new in Cubase 13).

image

The expected result when using MIDI Modifiers to transpose is that the notes in the Key Editor will be displayed in their original pitch but played transposed according to the Modifier setting. This includes selecting a note with Acoustic Feedback ( image ) turned on.
Is this the behavior you’re getting?

MIDI has worked like this in Cubase for as long as I can recall.

Depending on what you are trying to achieve one approach often makes more sense than the other. For example when using MIDI Modifiers or Inserts they always leave the MIDI Parts on the Track unmodified and only change the MIDI Data as it is being played. One advantage of doing it this way is that the settings for Inserts & Modifiers can be Automated and change over the length of a piece.

So you could have a MIDI Part one bar long playing the left hand of a boogie pattern over a C chord; duplicate the Part a bunch of times and Automate the Transpose value so it will play a C-F-G-C progression. Or consider an arpeggiator. Your MIDI Part might be a one bar block chord, but the arp is spitting out 1/16th Notes right & left. There are also randomizing functions which only make sense during playback.

Using the Info Line in the Project Window to Transpose a MIDI Part also only effects playback. This can be useful when auditioning VSTi’s letting you easily jump up and down by octaves to suit different sounds.

Personally if I want what’s in the MIDI Part to exactly match what gets played I’ll almost always directly edit the MIDI Part - either using the Key Editor or Logical Editor Presets in the Project Window. If I’m transposing by another method I’m doing it specifically to not modify the source data.

That said you can ‘capture’ the results from the other methods. However I rarely do that, so others will have better advice on that. Which I’m also interested in reading.