Possible to Un-format text in Wavelab?

Does anyone know if there is a way to unformat text in Wavelab to prevent things like an apostrophe pasting as 3 characters of gibberish as shown in the pic? I’ve seen an apostrophe paste as a question mark before. I suppose I could paste everything into a word processor and have formatting stripped but how awesome it would be if there was a checkmark to do this in Wavelab.

+1 for all points of data/text entry.

I have noticed that this seems to happen when you copy-and-paste from a text or office document created on OSX. There seems to be “something” about how that is handled in OSX.

If you have an OSX plain text document and open that in Windows 10 it ‘looks’ normal. But typically if you copy-and-paste from that it can (but not always) produce the weirdness you are describing.

All our office and supporting machines are OSX (including two brand new iMacs) but my main studio machine is Windows 10 which is how I came to notice this. All machines run office 365 and the OSX text file preferences are set to “plain text” so there is no mis-match in apps.

Honestly, is there any case scenario where formatting would need to be retained in the text? Shouldn’t the default be to strip it all to avoid potential blunders? If you’re running batch files or just rendering a ton of files, it’s kind of a bummer to discover it after-the-fact and have to manually apply a new metadata profile to everything you just rendered.

And no comment from PG??


Is this OS X related or only the case with WaveLab ?

regards S-EH

I’m on Windows 10, primarily only using audio applications so I haven’t noticed this issue otherwise.

I noticed this as well yesterday trying to paste metadata in ixml tab. It kept turning the < & > into useless strings, no matter what text editor I pasted it from, even when I made sure it was the same unicode format as the header.

orangeoctane, I know you’re asking for an option, but whatever’s decided, I’m still going to need to paste Spanish, German, and French words with accents into CD Track names, if the solution would be affecting that. (actually don’t know if it would).

I just want a WYSIWYG solution!

I agree with you, but they already paste into CD Track names wysiwyg. It’s only when they hit ascii restricted CD Text that they appear as garbage. It’s pretty surely because of default Smart Quotes in most word processor auto correct preferences, which turn straight single and double quotes (and apostrophes) to curly quotes, as pwhodges noted in a thread a while back.
Maybe there’s a possible fix, but I don’t think a solution was presented then.

I don’t think that would make any difference, having just tried it. I think it’s more than just formatting or plain text. It’s maybe converting characters to their ascii equivalent, but who says what the ascii equivalent is? I guess in these cases it obvious what the ascii equivalents are, but I don’t think there’s any automatic way to do that even outside of Wavelab. Maybe PG could set up a way to specifically convert those characters that are commonly problematic, but I don’t find a simple answer anywhere. Maybe PG and others would have better ideas, because they certainly know a lot more about this than I do.

But it’s kind of a mess.

I guess my workflow allows me to catch this early but since all my metadata is populated from CD-Text (even if CD/DDP isn’t needed), I can instantly see in the CD-Text Editor Pop-Up Box (not the CD Tab) if there is a problem.

When there is a problem character, the CD-Text Editor Pop-Up Box displays a question mark and then I can fix it before doing any rendering.

I think that’s the best solution for now. You could uncheck “restrict to ascill” on the CD Text window before autofilling the titles, and all will probably look fine in the Text window and CD Report, but will most likely be garbage on the DDP or CD master, and if not, possibly garbage only on some CD players, if it works like accents. So unchecking “restrict to ascii” would probably be a terrible idea.