Post-fader plug-in's routing gets lost in multi-channel tracks

20210908_162842

Nope.
Tried it on a 5.1 track.
a 5.1 group
an Auro 10.1 track
and an Auro 10.1 group.

Routing is preserved.

Fredo

But you have seen the animated GIF above, haven’t you?

Yes. But I can not reproduce the behavior. So something else must be happening here.

Fredo

Any ideas what to watch out for? That’s an empty project, created from scratch (not even from a template).

Are you using Control Room?

Honestly, no idea.
I do use Control Room, but can’t see how that could be related.

Fredo

Total longshot, but since it seems like settings aren’t sticking when reverting after saving, could you try to do more things before saving and also take a look a the file in the finder to make sure it actually saves properly?

Thanks for the suggestion, @MattiasNYC . I did that kind of troubleshooting already. Thing is that all other data (including pre-fader routing!) is recalled as expected. I don’t use post-fader multi-channel inserts that often, but there’s always a very good reason when I have to do so - which makes the whole matter even more toilsome.

It was just a wild guess, because I’ve seen Nuendo react differently with or without Control Room when it comes to re-loading Projects.

Just to make it perfectly clear: This happened on different machines, different OS, using different versions of Nuendo, without any ported templates or the like.

Dietz,

Seems your initial repro is not correct.
As said, I have tried this in all possible ways, so did Martin.

But … looking in detail to your video, you do something completely different.
You are using “Revert” instead of closing and reopening the project.

So I can reproduce when using “Revert”.
But I think this is normal behaviour, since these kind of actions in third party plugins are not beging recorded by the Undo History. I THINK this is the explenation. (haven’t had the time to test)
Will file a bugreport, but I have a strong feeling that it will come back as “as designed”.

Fredo

Thanks, Fredo.

Just to avoid any confusion: I used the “Revert”-command only to make the procedure as fast and obvious as possible for the screenshot. Of course the issue also appears in case of re-loading Projects on the next day, on a freshly booted machine.

From earlier post from me:
“I use ARC2 for room correction to finalize my room acoustics.
As it is stereo only I have 3 of those on CR inserts. One for L/R, one for C/LFE and one for Ls/Rs. Not perfect solution but works…
Upon opening a new project I always have to first route these right and then select correct settings.”

Hmmm… Strange that I can reproduce it with “Revert” and not by simply closing and opening the project.
The only thing I haven’t tried is closing Nuendo completely.
I just closed and reopened projects.
Will try to do that when I find 5 minutes.

Greetz
Fredo

Dear Fredo,

It makes no difference here whether I shut down the machine in between or just reload the project.

Hi,
I saw the different position of the “Postfaderslotpositionline” :laughing: in your screenshots.

I tried myself and could narrow it down a little further I think.
I now have a Project with two multichannel groups.
Group1
-Post fader insert line between Insert 15 and 16
-Insert1 stereo plugin L/R
-Insert 16 stereo plugin on last two channels

Group2
-Post fader insert line between Insert 1 and 2
-Insert1 stereo plugin L/R
-Insert 3 stereo plugin on last two channels

Group 1 is always recalled correct,
group 2 is always recalled wrong.

This might explain different results, when different people tried to reproduce.
I did not dig in deeper, whether it is the Insert position or the post fader insert line position, or a combination of both.

Cheers,
Dirx

1 Like

Huh! :hushed:
Thanks for pointing out that small, but remarkable difference, @Dirx ! I’ll give it a try myself ASAP.

BINGO!!! @Fredo :slight_smile:

@Dirx has given the hint to the crucial variable! I can confirm that the error described in my messages and tests is indeed and reliably dependent on the position of the plug-in in respect to the fader. Multi-track routing for post-fader plug-ins is recalled correctly only in slots 11 and 12. In all other slots, the routing is reset to default in a post-fader position, regardless of where the fader is placed.

… to make things even more complicated, even pre-fade multi-track routing is NOT recalled properly in slot 11 as soon as the fader is moved to the position between slots 11 and 12.

Here is a simple test project that show-cases the issue:

NU11Routing Test4.npr (452.8 KB)

@Steinberg: Please fix.

Will bugbase this.

Fredo

Thanks a lot. I’ll give it a bump, every now an then. :sunglasses: