Power Management - Monitor sleep not possible

I’m not a fan for power management on DAW but it is good if the monitor goes to stand by after some time to save material and energy. In Cubase 7 this is not possible anymore.


  1. Open Cubase
  2. Wait the time you set Monitor sleep in energy preferences, in my case of Windows 7 64bit
  3. Monitor does NOT go to sleep

By they way, of course I did not set the option “Steinberg Power Profile” in preferences in Cubase 7.
A fix would save energy worldwide.

Any resolution to this issue? I too am having a problem with Cubase 7 where my computer monitors keep turning back on after I have set them to go to sleep. I did not have this problem with Cubase 6.5.

I am running Cubase 7 on Windows 7 Pro 64 bit. I have 3 monitors conncted to my custom built PC:
2 Apple 24" displays (connected via DisplayPort) and an older Samsung 20" display via DisplayPort to DVI.

I would just turn off the monitors but the Apple displays do not have a power switch. I finally just connected the monitors to a power strip and I manually turn the power off on them when I get up from my studio for a while. But this is like yanking the power cords from the monitors. Not the best idea.

Here’s a shot in the dark…

Go into device manager and look at your the properties for your Network adapter. Under the Power Management tab be sure that allowing your NIC to ‘wake’ the computer is ‘disabled’.

Also check you USB devices for the same thing while you are at it.

Hope this helps.

Followed your hints. But nothing. The moment I start Cubase. Monitors do not fall asleep anymore. If I quit Cubase. Everything works fine. Seems to be a bug in Cubase!

Old topic back up sorry, but I’m experimenting the “not going to sleep monitors” issue with all windows settings set right.
Everything works with the monitors turning off until cubase is on.
Anybody found a workaround for this ?
I’m still on C7… please don’t tell me to put C9 and it will work. I’m not following steinberg’s marketing of “please update and pay” for features I don’t need.
And please if you come with new releases, please fix the issues, don’t add new ones.

In Cubase 8.5.20 the problem still exists too!

little workaround but not the best.
find the file scrnsave.scr in your windows drive.
put a shortcut on the desktop…
you can then also put a key command to activate it, they don’t work all very well depending what software you’re focused on. CTRL+F12 as an example seems to work ok here.