Pre Filter HC/LC Bug

Hi all, I have a very annoying behaviour here on N7.1.20

I was hearing strange things on a mix while tweaking Pre Filters (HC & LC) so I decided I had to test this with a pink noise generator :

REPRO :

  • create one audio track routed to stereo out, insert test tone generator set to pink noise
  • On the stereo out track (you can’t do this on the audio track itself for the pre filters are pre-insert), set the HC filter to lets say 6 KHz and 6 dB/Oct (something very audible)
  • Just turn ON the LC Filter hitting the power button of the LC (default is 20 Hz 24 dB/Oct)
  • Your HC is screwed (you can hear a lot more high frequency content but it is definitely not like if it was turned off
  • Turn OFF LC and your HC is back to normal

Can anyone confirm this please ?

  • Now even stranger, instead of turning LC ON with it’s power button, you can just click and drag the frequency slider of the LC lets say you drag it to 130 Hz (LC becomes active automatically)
  • Your HC stays normal
  • Turn OFF and ON again the LC (frequency stays at 130 Hz)
  • Your HC is screwed once again

So, the workaround seems to be to NEVER activate a LC with it’s power switch

BUT and this is the worst part so far

  • If you use a 6 dB/Oct setting on le LC it screws up your HC no matter what
  • The only way to have your HC working normally again is to turn OFF the LC either with it’s power button, or by draging the frequency back to under 20 Hz (which switches it off automatically)

EDIT : This only seems to be the case with a 6 dB/Oct setting on the HC Filter, I can’t seem to reproduce any of this with other slope values on the HC, so my workaround ATM is to STAY AWAY from the 6 dB/Oct slope on the HC filters !

Best regards
Yannick

Win7 64 / N7.1.20 64

Confirmed.

Please change your thread title so that there’s no question mark at the end of it.

This is terrible. In practice this means that I can create a mix with high-cut enabled, everything sounds fine, and I then decide to try something using low-cut which then increases my high end.

Awful, awful, awful…!!!

I assume this is NOT how it’s supposed to work…

PS: I think I had to go back and forth a bit in your repro to get the result you were talking about, so it might be worth it for you to go back and re-write it to be clearer…

Confirmed - great catch.

  • Create audio track
  • Insert test generator set to noise (to easily see)
  • Create group track
  • Route audio track to group track
  • Activate HC 6dB/8ve on group track
  • Turn LC on/off via power button
    –> HF is increased for the channel when it should not be
  • Instead of turning LC off via power button drag freq to minimum value
    –> HF is not increased

Only occurs with 6dB filter slope as you said. See attached images.
lc_off.png
lc_on.png

Don’t have time to elaborate now, but I don’t think it’s limited to that filter slope.

Confirmed.
It occurs when either of the cut filters has a 6 dB slope.

Regards.
Andreas

Thanks for confirming the bug.

From what I have tested so far, there is a workaround for using a 6dB slope on HC pre filter, that is to never turn on the LC filter with it’s power button and just dragging the value of the LC.

BUT if you choose a 6dB slope on the LC pre filter, the bug always happens either way (turning on the LC power button or dragging it’s frequency value…)

So for now you cant use 6dB slopes on both the HC and LC filter. at the same time.

Best regards
Yannick