Preload project into cache


During the first playback of revisited projects, Cubase chokes for a second when loading sounds into its cache. That will happen for every additional instrument that begins to play, usually in various parts in the song. That makes an initial listening of a song unbearable as it will choke in the beginning of the first verse, the prechorus, the chorus, c-part etc. It will however get smoother from the second listening throughout the working process.

I was wondering if there is a possibility to force Cubase to load all the instruments and tracks into cache from the moment it will load the whole project so it won’t need to choke on the initial playback.

Compared to Pro Tools, Cubase is more stable in that regard as it will however continue to play where in Pro Tools it will stop the playback. But I feel it could be a real improvement if the DAW would load everything into cache from the beginning instead of me being forced to play through just to be able to play it smooth afterwards.


I would try to increase the Buffer Size.

Cubase cannot load everything to RAM, because it’s not on Cubase side. Cubase just sends MIDI data to the virtual instrument and the instrument loads the sample (or process the MIDI data own way).

The solution would need to send all MIDI Notes (with the correct volume) to the instrument(s), so the instrument(s) would load the samples to the RAM.

You don’t say what sounds. If audio tracks have you made sure the drive with the clips on is not going to sleep?

As mentioned above. If it’s vst instruments the management is within the instrument. I use SD3 drums and it has the option to load the full kit into ram. Others stream from disk which again could be your problem if the disk is not responding. These also have settings.

I understame. I do have SD2 and it is as you describe that you can choose to load the files to the cache.

But this fenomenon happens also when reading simple audio events.

Have you changed the power scheme so that drives don’t power down? I had this although only at the beginning of songs when my pc had been idle for about 20 mins. I used my own power scheme and not steinberg one but a windows update put it back into balanced. It does sound like the drive is having to wake up to play the files. Are you using an external drive? To test drop a project into your C drive that suffers this and see if it still happens.

Thank you for your input.

I am using a mac, but have already changed the power scheme to disable hard drives sleep when I first bought the computer. However, all my projects are living in the internal hard drive as this computer is mainly used for music production.

Maybe one for the Mac guys then

1 Like