Presets menu HANGS/SLOW! Why?!?!?

Whenever I click on presets Cubase hangs for a while, and it is so slow. It’s the same with track presets or VST plugin presets. Not to mention the slowness and errancies of Media Bay. I’m on C10.5, but this problem has been around for a few versions.

anyone?

I think I know what you mean. It’s like it quickly rescans or something before the window opens.

It doesn’t quickly rescan. Takes a long time, sometimes crashes. Every freaking time in any preset window.

if you have media installed and that needs to be scanned on drives, you could check if the drives turn down while not busy. If the drives do, and a preset scan is needed, it takes at least 10 secs for the drive comes available for searching. The more drives you have, can be a problem. So find out if your drive does turn down while not busy. Or set windows to keep the drive available.

I’m on MacOS Mojave. I do have 6 external SSD drives, and they are all active. But what do those drives have to do with VST plugin presets or track presets? Maybe Media Bay.

You can set the drives to never power down inside the Energy Saver settings. Maybe try that.

That option is already off.

Have same problem.
Tried several times rescan All media (vst sound, Steinberg content) checked ONLY folder with presets, samples, and Steinberg content. All slow at almost every presets or folder.

Don’t know how to fix it

Not to mention the slowness and errancies of Media Bay. I’m on C10.5, but this problem has been around for a few versions.

Had the same issue. Deleting cubase preferences in user/library solved it for me. Just drag it out to desktop or somewhere as a back up just in case you want to put some of it back because it wipes off all custom stuff.

Thanks. This seems to have solved it. Although my preferences are now gone!

You are right somehow the mediabay can be slow , specially reading own user preset folders scans.