PreSonus FaderPort 2 (2018) midi remote script

I’m new to the surface controllers and cubase. Looking at the script setup doc, I’ve copied the js file to the appropriate place ( I see it in the midi remote script files) but nothing happens. I guess I need to do some more setup, I see also setup as studio one and do not setup as mackie controller. Do I need to do some setup from the Presonus install doc or something. If someone could point me to setup doc that would be great. Thank you for your help.

Maybe someone could help Mark_Motherway.
I’m very busy at the moment…

Hello friends,

here comes the promised new update (version date: November 19, 2023).

Explanations and operating instructions for the new extensions

  • special memory functions for EQ for to write / read up to 5 sets of 20 values
  • special memory functions for value under mouse for to write / read up to 5 values
  • single button special memory write / read functions for EQ for all 20 values with LED feedback
  • single button special memory write / read functions for value under mouse with LED feedback
  • reset functionality for special memory functions with button combination
  • fast rewind with double speed with button doubleclick
  • fast forward with double speed with button doubleclick
  • extra direct motorfader functionality for sending MIDI data to MIDI tracks
  • all three motorfader functionalities with LED feedback
  • automation now with fader touch recording
  • other various improvements

can be found in the zip-file in the release notes.

Here the complete zip-file: (1.1 MB)

Best regards :innocent:
CKB (Christian)


Christian, here’s as different question. I recently picked up a used Presonus ATOM controller for Groove Agent. It automatically does what I need it to do in my Cubase Project, which is to simply have it’s 16 pads identified by Cubase, such that I can play/record beats via MIDI.

But here’s the thing, I downloaded the Presonus update firmware for the ATOM along with the driver files (that includes 1 Control) and I found most if not all of this to be unnecessary. Cubase found the ATOM without any help - so - I decided to uninstall the added 1 Control and all the driver files I didn’t need. I eventually got there but it was work - I found the Presonus software attaches their software very firmly into Win11.

Q: Can the firmware and driver for the Fader Port (if they’re something new that is needed) be installed without the 1 Control and all the .dll files that are unnecessary? Odd, too, the Presonus app offers an uninstall exc file within the program folder but it will not let you remove the app.

Q: Will/can your script sort the Fader Port connection to Cubase without the Presonus bloat ware? Thanks!

I think I have got it working now. As I am using the ioStation24c I changed the directory and script file name to PreSonus_ioStation24c. I did not change anything in the script file. If I’ve done something wrong please let me know. Thank you and I hope to enjoy the controller.

@mr.roos, I can only report on what I can verify myself. I use the FaderPort under Windows 10 and when I open the Device Manager of Windows, I see the FaderPort there as “PreSonus FP2” and under driver details that it only accesses Windows system files. The script controls the PreSonus FP2 directly via Windows via MIDI native. And if I completely uninstall the “Universal Control” software supplied by PreSonus, the script works correctly. In my configuration, this software is most likely only there to check if there is a new firmware. As the “Universal Control” software causes some latency, I would generally not install it. Conclusion: The number of PreSonus files installed is zero for me.

1 Like

Thank you!

1 Like



Thank you to @steinberg to update the midi remote api and to @CKB for the extensive work with the script.
Now the touch fader works as expected in automation recording.

I have a Presonus IoStation24c working in Nuendo13 in two computers, one with w10 and the other with w11.

1 Like

Hello CKB,

Thank you for the troubleshooting instructions. However after doing the following:

  1. Installed the latest UNIVERSAL CONTROL Software from PreSonus, Version
  2. Reloaded current Firmware v3.74 was installed although, it was on the latest version.
  3. Ensured the Fader Port was for Native Studio One buy switching off the FaderPort and pressing the Next button while powering on the
    FaderPort, and after the FaderPort’s lights illuminated, I released the Next button and then press the Solo button.
  4. Navigated in file manager to C:\Users\YOUR USERNAME\Documents\Steinberg\Cubase\MIDI Remote
    \Driver Scripts\Local\PreSonus\FaderPort and ensured the PreSonus_FaderPort.js copied over.
  5. Before launching the FP & Cubase I navigated to c:\Users\YOUR USERNAME\AppData\Local\Temp and deleted everything I could with administrivia rights.
  6. My computer was up and running as I turned the power on the FaderPort.
  7. Launched Cubase 13 and on the did not connect. I then disabled and reenabled the script in the Midi Remote Manager. Then only thing that happened was the Pan button light lit up Yellow. I’ve disabled and enabled a few times to no avail. No other buttons work. When I select a track with a different volume level in Cubase the FP dos move the fader, I have no control with the Fader on the FP. Basically Nothing works. As a Note: I do get the Mackie Control to work with Cubase except for automation, and even at that it comes and goes.

Hi david,
have you tried again with the brand new script from November 19th?
Another possibility would be to do a test with the FaderPort as the only MIDI device.
Do you use Win10, Win11 or MAC?
If I have understood you correctly, you have the problems only with Cubase 13. Maybe the problems will be solved with the next update of Cubase 13. I think such an update will come soon.

New user here and have pretty much done what @davisda1 did.

  • Installed Universal control (just the application, so no drivers etc)
  • Updated Firmware
  • Selected control mode
  • Uninstalled Universal control
  • Created the folders and copied the script over
  • Ran Cubase 13 (Win 11)
  • Checked midi port settings - so disabled ‘All midi inputs’
    Everything is working :thinking:

I’m still on the Nov 9th script as I’m not sure yet what ‘special memory functions’ and ‘fader touch recording’ even means :smiley:

I explained what ‘special memory’ is in the release notes for the November 19 update:

special memory
As an extension of the EQ Mode and the ‘activate knob for value under mouse’ Mode
‘special memory’ is provided.

In EQ Mode, this allows you to save up to five complete EQ sets. Each EQ set comprises 20 parameters, namely the five parameters
on / off, gain, frequency, Q-factor and also the EQ filtertype for all four EQ bands.
The five ‘special memory’ memories are available in the entire project as long as the script is loaded. You can now experiment with different EQ settings quickly and directly from the FaderPort, i.e. compare different EQ settings or transfer them to other tracks.

The new LED colors for ‘special memory’ have the following meaning:
Memory empty = violet, memory written to = orange-red, memory being overwritten = magenta, memory readable here = light green.

The ‘special memory’ is operated using the Write Button and the Read Button.
These two Buttons themselves represent the quick memory = ‘special memory’ 0.

If you switch to EQ Mode for the first time, the Write Button and the Read Button light up violet, as ‘special memory’ 0 is empty.
By pressing the Write Button, all 20 EQ parameters are now written to ‘special memory’ 0 and then the Write Button lights up orange-red and the Read Button light green. Now you can read the saved EQ parameters with the Read Button or overwrite the previously saved EQ parameters with the Write Button. When overwriting, the Write Button lights up magenta as long as it is pressed.

As long as the Write Button is pressed, the LEDs of the Buttons Link, Pan, Channel and Scroll also light up.
These four Buttons Link, Pan, Channel and Scroll represent ‘special memory’ 1, 2, 3 and 4.
If you hold down the Write Button and press one of these four Buttons, the EQ parameters are not written to ‘special memory’ 0, but to ‘special memory’ 1, 2, 3 or 4 or are overwritten there.
It works in the same way with the Read Button and reading the EQ parameters from ‘special memory’ 1, 2, 3, 4.
If you press the Write Button and the Read Button together at the same time, ‘special memory’ 0 to 4 are deleted.

‘special memory’ works in the same way as in EQ Mode in ‘activate knob for value under mouse’ Mode.
Five separate ‘special memories’ 0 to 4 are also available for this Mode.
It should be noted that the script does not know the meaning of a parameter saved as ‘value under mouse’ with ‘special memory’. When using it, you must ensure that writing and reading takes place between identical or compatible parameters.

You will also find explanations of the other extensions in the release notes.

1 Like

Sorry, when I said ‘I’m not sure yet’ I meant that I had just not read the release notes, which I was planning to do so.

Thanks for the explanation, and that plus the notes should make it all clear.

To be honest though, I hardly use most of the features of the script and just try and keep to the basics of transport, fader, mute, solo etc.
That alone makes it worth the purchase, and I really appreciate what you have done to make the device usable, and without finding this thread I probably would not have bought one.

I can imagine though, that as my muscle memory improves I may try some of the other features, for now though, one wrong press and the thing goes off like a Christmas tree :rofl:

1 Like

Christian, thank you for this response.

In Win11, just turning my PC on put the Universal Control amongst my hidden icons on the Task Bar. It did not wait for me to initiate the app icon on my desktop as other apps typically do. And then the uninstall process was complicated. BTW, I first ‘closed’ the icon in the hidden Task bar before trying to remove the program. To remove the program I tried the CClean program, but no joy. Next was the ‘uninstall exc.’ file in the Presonus folder -but it did not behave as other apps ‘uninstall exc.’ files behave. In both attempts the CClean and the Presonus ‘uninstall exc.’ file told me that the Universal Control was open on my PC. (It was not.) To get the app off my PC, I ended up moving maybe 3/4 of the files out of the Presonus folder, putting them in an empty folder on my desktop, restarting my PC, removing a few more files, restarting again, etc., and eventually emptying the Presonus folder of all files except for the Universal Control exc. program that (as I recall) I finally was able to drag into the Recycle bin and delete. All the while I was signed into the program as the ‘Administrator’. Not impressed with the Presonus program at this point as you can imagine. However, I am impressed with your work, and I appreciate hearing from you that I do not need the Universal Control on my PC! Thank you, Christian.

1 Like

Hi david,
as a supplement to my answer

have you tried again with the brand new script from November 19th?
Another possibility would be to do a test with the FaderPort as the only MIDI device.
Do you use Win10, Win11 or MAC?
If I have understood you correctly, you have the problems only with Cubase 13. Maybe the problems will be solved with the next update of Cubase 13. I think such an update will come soon.

this could be also interesting for you:

Simonz said here, he made a change in the setup of Cubase that solved the problem for him.

He set this setting in Cubase to disable for the FaderPort:
Studio > Studio Setup > Remote Devices > MIDI Port Setup > All MIDI Inputs > disable

Does then everything work for you as it does for Simonz?

Actually, the script should also work if All MIDI Inputs is not disabled, i.e. the actual cause should lie elsewhere. And… the new (third) motorized fader functionality ‘direct’ requires that All MIDI Inputs is not disabled.

The new function Fast Forward with double speed runs even faster than a Christmas tree, even faster than Speedy Gonzales.
It’s a pity that the FaderPort doesn’t have a speaker, otherwise I would have programmed this function so that the FaderPort shouts “Huiiii!!!” every time you do a Fast Forward. :innocent:

1 Like

I seem to recall I disabled midi input as it was triggering notes when some buttons were pressed. But thinking about it, is that not how MCU works, so maybe it bugged out for a moment.

Hello Christian,

I am on the Nov 19th script. I have reimplemented the script. And using the FP2 with the Mackie Control works with it’s limited features for Cubase. One of my biggest problems in trying to troubleshoot this issue is CPU Spikes, they really need to fix this and fast. So I’m going to start a brand new project with just a few tracks and try to use the FP2 with the script as I would normally as it works nicely up to the point of a Spike on the other project. I’ll keep you posted. Oh! I’m not sure what Simonz means by disabling all midi ports as for me I tried, and the FP2 doesn’t work at all. And when I go to enable the Midi Remote script it’s not highlighted for selection.

Addendum - Ok, so now I have a small new project in C13 and right off the bat Nov 19th script was working like a charm and then all of sudden C13 craped out with CPU spike and I just built this computer so I know it powerful enough, and then the FP2 with the script stooped working. I could disable/enabled the script and the Pan light would lite up but I couldn’t use the FP2 at all. Start/Stop/any buttons etc. would not work. I then decided to launch C12 and see if the script would work there. And again it started out fine and then all of sudden it the FP2 just stopped working I tried un/enable the script to no avail. The thing just get’s stuck. I also have Cubase folders excluded from antivirus scanning. So I know it’s not that.

For now I am going to have use C12 for my mixing projects with the standard Mackie Control for the FP2 until things get updated but even at that I can’t use automation fader for some reason. I hope the FP2 is going bad or something It’s only little over a year old.

It was the ‘in all midi inputs’ I was unchecking, not the device IO.
Unless the device is faulty, I wonder if its USB connection related as you says its a new build. Have you tried a different port?
I’ve had USB issues in the past relating to USB power management sleeping ports, but they were not externally powered.

Apart from some GFX glitches (which a workaround was issued) I’ve not had any issues with CB13 , I’m aware a fair few people have though.

Hey Simonz,

I think your are on the right track. I was poking around and went to my Device Manger and discovered it was refreshing every so many seconds. Researching, it’s leaning towards a bad USB connection somewhere I have lots of USB Connections and will have to find out which one it is. Meanwhile I did just finish updating the Graphics card driver, to get that out of the way. Oh, and to answer your question yes, I’ve tried different ports.