PreSonus FaderPort 2 (2018) midi remote script

Unfortunately, I haven’t been able to get this to work. Some basic, step-by-step instructions might help. For instance, I tried to power-off my FaderPort 16 and power-on holding the NEXT button, and then touching the SOLO button. Except there is no SOLO button – each channel has its own SOLO button but, is that what is meant?

Also, I tried to import the .js file in Cubase 13’s , but got an error: Script Archive could not be imported". Again, clear step-by-step instructions might help.

I am afraid the script does not work with the Faderport 16, it is for the single fader Faderport V2. I don’t know if there is a script for the Faderport 16. Maybe you can try the Midi Remote Editor and see if you can make one from scratch? It is not as hard as it sounds. Here is a pretty good guide: https://www.youtube.com/watch?v=Q1ocxUbeXJE

Simonz set this setting in Cubase to disable for the FaderPort.

You find this in Cubase under
Studio > Studio Setup > Remote Devices > MIDI Port Setup > In ‘All MIDI Inputs’ > disable/enable

Here is a screenshot, what this looks like in Cubase, where you can find it.
(I have installed the German version of Cubase.)
In my case (my example) the In ‘All MIDI Inputs’ setting for my Focusrite audio interface is set to disable and for the FaderPort to enable. You should try to set this setting for the FaderPort to disable.

If this does also not work, remove ALL USB devices and all USD hubs from your computer. Plug your FaderPort into a single USB port and test again.
If that doesn’t work either, I would wait for an update of Cubase 13 from Steinberg.

Hey Simonz & CKB,

I have solved my Faderport 2 issue. I noticed that once getting configured to use the FP2 in CB13 or CB12 using the Nov 19th script, Cubase would recognize the FP2 just fine for a minute or a few seconds then just stop working. Once I realized this was happening in both CB12 & 13, I deducted that something had to be interrupting the MIDI connection. I checked & updated all my drivers but when I was in the Win Device Manager I noticed that it was constantly refreshing at times, sometimes every few seconds or even up to a couple of minutes. So now, hopefully I thought I would chase the real problem as in the Device Manger refreshing vs. something with the FP2 or the script. After researching I found that once I disabled the SSDP Discovery service the refreshing of the Win Device Manager stopped. I then went back to Cubase and BOOM! problem solved.

Note: The SSDP Discovery (SSDPSRV) service discovers networks devices and services that use the simple service discovery protocol (SSDP), such as Universal Plug and Play (UPnP) devices . For example, the UPnP Device Host service uses SSDP to locate and identify UPnP-certified network devices and service. Come to find out it’s more of a security risk especially if your running on a wireless network of which I’m not. I sopped it and set to Manual. I will not miss it one bit.

2 Likes

Ohhhh…my mistake. That’s obviously why. I missed that. That’s obviously why everyone refers to it as “the SOLO button” – because there’s one channel, therefore one solo button. I also don’t know if there’s a script for FaderPort 16 but I have no hesitation about trying to make my own. Thanks for the insight!

Perfect, David. :grinning:
Nice to hear that everything is working for you now.

Dear CKB,

thank you so much for the update, I tested the Midi Motorfader Direct Mode and it works perfectly (and in cyan)! I wonder, would it be possible to send CC1 as default instead of Pitchbend? It would make things smoother and easier , it’s the most common CC and it could be used without a Transformer and copied as it is to other CCs lanes.
Last, what’s the resolution of the midi data from the fader? In Pitchbend mode it’s surely lower than the one sent by a Pitchbend Wheel from a keyboard, but maybe that is an hardware limitation.
Please ignore all of this talk if you don’t care of have no time, everything is wonderful already.
All the best, Mattia

No, because PitchBend (high resolution) is what the FaderPort sends.

If you have experimented a little with the Input Transformer, you can save your settings there as presets. Then everything is pretty easy to handle. You need the Input Transformer anyway if you also want to filter the note on/off commands that the FaderPort sends for some buttons. There are videos on YouTube about working with the Input Transformer. There you should also understand what it means to work with several modules in the Input Transformer. It takes a bit of time, but you manage to understand it, I think.

Here are two presets, generated with Cubase, that you can load as modules at the same time.
If you do this, 1. all note commands will be filtered and 2. the PitchBend data will be transformed into CC 21.
No Notes.xml (2.5 KB)
Pitchbend to CC 21.xml (4.2 KB)

1 Like

Just a general question. I have an instrument channel selected and I press the start button it pings a note of that instrument and if I press stop it does it again. Is this normal behaviour? Please note I have the iostation 24c not the Faderport.

You must adjust the MIDI Input of the FaderPort here:

Studio > Studio Setup > Remote Devices > MIDI Port Setup > In ‘All MIDI Inputs’ > disable

Note:
This setting must be set to enable, in the case of Motorfader functionality = direct.

Getting back to davisda’1 and his USB problems, I discovered that - although years ago using Win10, where I set up the function to never turn the USB connections off, my USB connections were suddenly turning off. Opening the Device Manager, I opened the ‘Properties’ of each and every USB line on my PC. I discovered that the ‘main’ USB connections will have a ‘Power Management’ tab. When I opened this tab, I found that each one had the box checked that read “Allow the computer to turn off this device to save power”. I unchecked this box and my connection problems were solved.

I am thinking that a recent Win11 update created this problem.

BTW, I’m running the latest Win11 update, 23H2/OS build: 22631.2715. Perhaps all Win11 PC users should take a look at this.

1 Like

Simply: THANK YOU CKB !!!
The troublshooting pdf is GREAT !
also Thanx to mr.roos ! Very useful advice to win11 users.

1 Like

I have just connected a footswitch and I find that I have to press it twice to make it work both to get it to start and to get it to stop. Did I simply buy the wrong kind or is there a setting somewhere that can be adjusted? It is a Fender one-button on/off footswitch.

This is actually not the right switch,
but it may also work if you make the following manual change in the script:

Open the script (version from November 19, 2023) with a simple text editor and change the code of line 6312

from
if (value == 1) {

to
if (value != 2) {

Perhaps this will help you.

Great! Thank you. I will try this on Monday.

Great stuff! It worked perfectly. Thank you again for your amazing work!

1 Like

*** update news ***

Hello friends, a curious user asked me if there will be another update and - if so - what will be new.

Here’s the answer for everyone: Yes, there will be a major update. Quick Controls (all eight of them) will be added for all tracks and also for controlling plug-ins. The Quick Controls will be implemented in such a way that then they can also be recorded as automation data.

If you are interested in this feature, please give me feedback with a like.

Best regards

CKB :innocent:


Supplement
I was asked today (January 11th, 2024) , when this update will be available here at the Steinberg Forum.

Answer @all:
I’m trying to get it ready at the weekend.
So we’re talking about January 15th, 2024.
:sunglasses:

18 Likes

Thank you for your fabulous work!

2 Likes

First of all thanks for your fabulous work! One thing I always miss when I am installing it is to document the folder where I need to put the js file. I am on mac and I never find it.

Maybe is worth to add it on the setup pdf.

1 Like

This is where it needs to be, just made it and works:

/Users/{username}/Documents/Steinberg/Cubase/MIDI Remote/Driver Scripts/Local/PreSonus/FaderPort/PreSonus_FaderPort.js