PreSonus FaderPort 2 (2018) midi remote script

Hello @u-man and @snattack,

In the first version of Cubase 12.0.x controlling of MIDI tracks did not work but the issue is fixed in the while. In Cubase 12.0.52 controlling MIDI tracks is working fine. If I remember it right, than it was fixed in 12.0.50. Controlling effect channels is still not working.

I would expect that Nuendo 12.0.52 features the same updates and fixes as Cubase 12.0.52. As I don‘t have Nuendo I can not try this.

Br
Werner

Thank you, I’ll try to update my version and report back. I’ve postponed the update since I wasn’t sure if it it would break your script.

Hello,

I’ve this issue now for about 4 days and cannot figure it out.

Environment:

Cubase 12 Artist 12.0.52
Latest Script 16.0.1
Faderport is set to work as Studio One
On Windows 10/64bit
Faderport 2018 Firmware 3.21

I haven’t had the Faderport 2018 very long and started using the script from WEN. Everything has been working great until the other day I was doing some automation on a plugin I tired to adjust the plugin with the song running and all of a sudden everything went jiggly like it was skipping a beat. I’m not even sure if my problem results from this but wanted to note.

Problem:

Unable to use most of the buttons on the Main Page to a certain extent. When on the Main Page the only button that will light up is Link and Click and they seem to work. I use the Marker button all the time and it seems if I hold it now for a couple of seconds I can get the Next/Prev buttons to navigate markers and I can insert a marker where my curse is in Cubase. Scroll only works with Next Prev. Basically the Know doesn’t work at all other than punching in a marker.

When I load an older project the Faderport works like it is supposed to. I have also gone into an older project and the Faderport worked fine and then later go back into that same project and the problem is back.

Steps Taken:

-Redownload the script and placed the script back in Cubase.
-Load Cubase with all Plugins deactivated to no avail.
-Changed Midi Ports
-Swapped MIDI Cable
-Reinstalled Sound Card/Video Card drivers for the heck of it.

Is there a file that is getting or not getting updated that I can rename or something. I’m pulling my hairy out here.

Thanks everyone.

Oh! and one thing I forgot to mention is that when I create a new project I’m getting the same problematic result.

To those who have problems:

Do you have the latest firmware v3.51 installed on the FaderPort?

Hey CKB I’ve tried with the firmware update and without to no avail.

I have had the same problem for quite a long time. Both on old and new projects. I am unable to see any connection to anything. I resolve it by disabling the script and then re-enabling it. But it is an annoyance. Cubase pro 12.0.52 on a Mac. Not sure which Faderport firmware I have. Will check it tomorrow.

@hegerber that worked!!!. Better than nothing. Now I can use the darn thing the way I got used to it. So it seems that something is interrupting the script as it loads on Cubase startup. I tried disabling any antivirus and setting exclusions for everything and that that didn’t help. But I’ll use it like this for now.

@hegerber I just updated the firm ware to v3.51 and your workaround still works. Thanks!!!

Hi @davisda1 & @hegerber,

I tried to reproduce the behaviour on my system. Unfortunately I was not able to reproduce the weird thing you describe. It doesn’t seem to be a general error in the script.
You already checked the basic things like updates for Cubase and FaderPort Firmware. It seems to be all fine.

As for now I don’t have any other ideas and approaches from the technical side. What I can offer is to make a Teams/Zoom session and have a look on your system/logs and configurations.

br
Werner

WEM and CKB your script is fantastic.
Every things works as expected on my PC: win 10 64 - Cubase 12.0.52 - Faderport firmware 3.51
Only fader is not in U position (slightly above U when Cubase faders are at 0.0 dB).
Not so important but is there a way to calibrate it?
Thanks

Useless? I use my Faderport 8 everyday, without this type of script. Not everything works, but it does what i want it to do Cubase Pro 10 - Setting Up the Faderport 8 - YouTube

Hello @osmizza001, thank you for your appreciation.

Regarding fader calibration: If I remember it right it‘s same as using MCU. Also there is a little offset. At the moment there is no calibration possibility implemented.

I will think about your idea and how it could be realised with the given circumstances.

@Freakwave It is good to hear, that you are happy with the FaderPort 8 and the MCU integration. But as you can easily see in this thread there is a lot of people that are not happy with the FaderPort v2 (with just one fader) and the MCU protocol integration. In my opnion this is not caused by missunderstanding or missing knowledge of how to use the FaderPort (or any other MCU based solution) in Cubase. It’s the limitations of the MCU protocol itself (MCU it’s now nearly 20 years old without any adaptions: e.g. the bankwise operation in combination with just one fader and many other things) and the poor adaption/mapping of PreSonus for not Studio One application.

I’m really happy that Steinberg introduced the MIDI remote API and opens us a way to create a modern and customable integration of MIDI hardware into Cubase with all the new possibilities.
I used the old integration for more than two year but spoken now only for me, the new integration speed up my workflow a lot.

It’s like everything new and every new technology: you can use it and one part of people will like the benefits. But there will all the times others that stick to the old technology because they are happy with it and don’t see any need for it.

Br
Werner

1 Like

@WEM
Thanks

WEM thank you so much for this script mate!
I’m using it for a long time already with Cubase 12 pro and it’s amazing.

I like to ask you something about it
When I’m switching between different sample rates, as 44.1,48,96
The section of the scroller in the faderport acts weird and stops to work at 96k.
Everything else works but the next and prev and the scroller doesn’t.

Seems like If I’m going back to 44.1 it still doesn’t work, only if I reset the faderport back to studio one mode, and then reaching again for a 44.1 project it comes back to full functionality

Is it something you’ve experienced? If it does, Can a solution be made somehow?

Thank you again!

Hi Werner!,
Well happy is maybe a to big a word to describe my state of mind regarding the Faderport 8 in conjunction with Cubase. I use it as follow; In the Project window it manages the volume of each track. Softly touching a fader on the Faderport, makes that track active, the transport buttons and all the other buttons i dont use (!) . I use a gaming mouse with 12 programmable buttons that does all the navigating through the project, record, loop, and other most common Key Commands.
Than the Faderport has MIDI mode. We are now in one VST and we want to contoll the paranamers. In MIDI Mode, every channel of the Faderport has preset CC channels (values). They are; Channel 1; CC1 (modulation), Channel 2; CC11 (Expression), Channel 3; CC 7 (Volume), Chanel 4; CC 10 (Pan), Channel 5; CC5 (Portamento), Channel 6; CC84 (free), Channel 7 ; CC2 (Breath control) and channel 8; CC 16 (free). As you can see most faders are locked to CC channels that are hard wired in most VST’s, like Volume, Modulation, Expression. If you assign them to any other funtion in the VST, the old function will persist and there by making it usseles. So i usualy use the faders on my Arturia Keylab 88 for that, not such nice faders…bat allas.
So am i happy?
No, i’d wich that PreSonus would set the CC Values free, so you can set them yourself (through software), that would make the apperatus much more usefull.

All the best and Rock on. :sunglasses:

Hi @WEM

The latest faderport script is excellent, but when it is running, selecting a different track, either with mouse or fp track selectors, causes playback to stop. Pretty frustrating. Is there a fix that you’re aware of?

Hi @scuzzywuzzy,

I can’t reproduce your described issue on my System (running Cubase Pro 12.0.52 on Win11 x64 here) in none of my projects.

A few question and hints:

  • Is you rFaderport configured in Studio One / Midi native mode? (press and hold next while powering on faderport, afterwards press the solo button to swtich to the correct mode)
  • Did you do any custom assignments in Cubase? If so, please remove them to let the script run pure. The script uses a lot of custom code to map the complex operations and dependencies. Custom assignmets can disturb the functionality in some cases.
  • If nothing helps, can you please give me some additional details about your project and configuration? May there is a special case I have not considered yet in my script and tests?

@all is anybody else with this issue?

br
Werner

Hi @ramelijah,

I unfortunately can’t reproduce you issue, too. Only thing I’m aware of is, that the scroll function acts diffently when project windows is active or somthing windows (different step sizes). This is a feature an not an error.
As the scroll function is dependent on the quantize setting. What setting are you using there?

br
Werner

Hi Werner @WEM

I checked the Faderport operating mode and also reinstalled the script but it behaves the same. I wondered if it was somehow maxing out the processor but i don’t see a peak in the CPU meter.
If I simply power off the Faderport, the project suddenly runs smoothly. Other projects behave the same regardless of how many tracks or plugins… hmmm

Mac Studio (2022)
Apple M1 Max, 64Gb ram
Mac OS 12.5.1
Cubase 12.0.52
script version 20230116