Presonus FaderPort problem

When trying to write automation with the faderport fader, the selected track change itself to another track the second i touch the fader.
It makes the faderport unusable.

Plus - when I moving with the arrows from track to track, it doesnt work in order (one after another) but goes in some kind of random way.

any clue?

Decided to pull out the FaderPort for old times sake and experienced the same issues.

First - make sure the firmware is current, there are significant complications with any older versions of the firmware.

Next - install latest version of the Faderport software from Presonus website.

Next - Restart System, Launch DAW and Faderport should work correctly. If it still doesn’t work unplug the USB while in DAW then plug the USB cord back in.

That seemed to get the FaderPort working correctly in Cubase 9 on a 64bit MacB Pro.

Thanx. i will try all that.

OK.

I updated the driver.
about firmware, I coukdnt find any and got this message from Presonus site "The firmware in FaderPort’s made after 2011 have firmware version 1.3.8. That is the last version and is the only version needed for these FaderPorts."

The situation is that the faderport is working and after a while, for some reason it does not. some time it is only the fader doesnt work.
on some tracks it do work. very unpreditable.

Create a PreSonus.com account and register the device using the serial number on the bottom. When you register the device it will tell you if your firmware is current or needs an update. From your post it sounds like you have a firmware issue.

I’m not so sure its a fader port issue, Im also seeing some issues with TouchDAW (using Mackie control). when flipping the fader for a ie; a compressor parameter it also jump to a complete different audio track

A few oddities here as well, inconsistent operation with a Faderport16. Toggling back and forth between ‘compatibility’ and ‘Cubase’ modes seems to temporarily clean it up.

Go to Preferences > Editing and toggle ON “Use Up/Down navigation to change tracks only”. See if that helps your issue. I am using FaderPort here on N8.1/Win 7 without any of the issues you describe.

If you notice, without this option selected, when you have an audio object selected the up/down arrows will scroll between audio objects on the different tracks and can select the track in a seemingly random fashion. I don’t know what to tell you about switching when touching the fader while automating. I’ve never seen that.

Good luck getting it sorted.

thank you, I will try your advice tomorrow.

Same problem here

tried your suggestion about the up/down track navigation - unfortunately I have the same problem .Moving the faderport classic volume fader causes a jump to the first track on cubase10

Solved it. Under devices for Mackie Hui - for midi in - select not connected. This did the trick for me !

Returned presonus, got cc121

Same problem here

Work around is to take the track you do want to do automation on, and move it to the top of the project

I had the same issue with the track select switching and sound cutting out every time I touched a fader but have fixed the issue it was in the Cubase Mackie Control settings you have to untick the Enable Auto Select box that will sort it !

I have this problem in certain projects. Had it with the Icon Platform Nano controller and sent it back. Now having the same issue with the Presonus Faderport so I think it’s safe to assume that the issue is in Cubase somewhere.