Presonus Faderport v2 not connecting

Hi all,
I just purchased the faderport v2 which has the perfect feature set for what I want to do except it doesn’t work.

  1. When I first plugged it in and loaded cubase and opened studio setup it automatically found the fader port. In the list of Legacy devices was listed “Presonus FP2”. But it did nothing.
  2. I read the manual and changed the setup mode on the fader port for cubase/nuendo and installed the universal control software.
  3. when I restarted cubase the presonus fb2 no longer showed in the list, I followed instructions to add the generic mackie controller, but when I tried to select midi inputs and outputs the new controller doesn’t show up in either dropdown list.
  4. I’ve tried selecting different combinations of midi in/out but nothing seems to help this thing talk to cubase.

I’ve done a ton of web searching and there is next to nothing about this.

Any suggestions? Boy I want this to work.

Did you try to wake-up the device by clicking the reset button in the device setup ?