Pressing Metronome icon (enable/disable) doesn't function while Recording / playback

Just to let you know that pressing the Metronome icon (to enable / disable the click) during recording / playback doesn’t function.
In cubase you can press the icon or press “c” which is metronome click enable/disable during the playback.
It is very useful if I’m in a middle of composition flow, and at the end I want to play rubato feeling towards the end, gradually tempo is going down, but I don’t want to stop the recording in order to disable the click, I just press “c” and then continuing till the end - although I know it will be written silly because it is not played in the right tempo - but at least I didn’t loose the idea while I’m in the composing flow, and can fix the notation later
Also happened to me few times already that I wanted to enable the click after start recording (where I noticed I don’t hear clicks), then I had to stop recording, press the metronome icon and start recording again. Same goes while listening to the playback of the recording and I hear the click - then I want to hear just the music without the clicks - need to stop playback each time… (a little annoying)

That’s correct, the button doesn’t function during playback either. It’s brand new functionality, so I’m sure there’s more the team is working on with it.

At the moment, all of the playback events etc. are generated before playback, and can’t be added or removed on the fly. But I think perhaps what we should really do is make the metronome button on the toolbar effectively mute and unmute the endpoint the click is routed to. However, I haven’t discussed this with Paul so I don’t know whether it’s a completely impractical idea.

Nice idea to just mute/unmute it when pressing the button.
Hope Paul will find it easy to implement. Thanks!