print output garbled ?

It happened a couple ot times to me, the whole page views in write & engrave modes are OK, but the print mode view is incorrect, some pages are missing, or incomplete pages which are out of order ?

My latest case of that for the guitar part score

  • in write mode, I can see that there are 4 pages in page view, zoom whole page, the last two being empty … but the galley view is OK

  • Then In print mode, there are only pages 3 & 4

I renamed the .dorico file as and the .pdf file as so I could attach them to this message. Just rename them to remove the .zip extension, don’t unzip them
Dorico Print Mode (5.77 KB)
Route 66 - Score - jPizzarelli 1 - (586 KB)

In Print mode you’ve selected a page range of pages 3-4. That’s why only those pages are exporting.

Thanks for pointing this mistake of mine.

That doesn’t explain why there are 2 empty pages in write mode ? is there a way to remove them ?

If I look at the right panel of Engrave mode, I can see you’ve got overrides on every page of the Guitar layout (and seemingly most other layouts).
They’re easy enough to remove (right click on any page, remove overrides) but they wouldn’t be there if you were using the Master Pages correctly.
If you don’t want the name of the project to show on the first page, then go into Layout Options and tell it to never use the First Master Page.
If you don’t want the name of the layout to appear at the top of each page, remove that token from the Default Master Page.

These are two examples of things you’re doing in sub-optimal ways; there are probably other issues but fundamentally the mistake is the same: if you don’t like the way something looks, deal with it globally. Don’t fix each individual occurrence or it’ll constitute a page override. Page overrides prevent Dorico from doing its job properly - it has to assume that if you’ve fiddled with page layout locally, you don’t want Dorico to change anything else layout-related on that page.

Thanks for all these tips,

Yes I did modify a bit some layouts here and there, along the time it took to transcribe the recording. Mostly on an adhoc basis, goal being to make some score not to exceed two pages for ease of use. three might be the max for live performance.

I even tried to find a way to reset everything to default, but didn’t find it.

Your suggestions point me to how handle things in a better way. Thanks.

NEVER MIND, I had “Duplex, both sides manually” set, and wasn’t paying attention to the order of the pages! Ignore the stuff below (I can’t delete this post).

_I had some weird behavior today with Print. I was trying to print one flow. First I tried printing pages 2-8, but it started with page 3. After fooling around a lot, I tried to change the setup just to my second flow, but can’t find any options to do that (despite hints in several posts here).

Finally I deleted the other flows. In Print it would not display page 1. Thinking it might be the master page, in Engrave I set page 1 to be the Default master page. Print still would not show page 1, nor the last page… starting to pull hair out. Restarted Dorico but it had the same behaviour.

Job type: Normal

Finally I went to Print and set the page range to 1-8 (although I only had 7 pages, I had forgotten there were not 8). Still would not display the first page in Print. So I set the range to “1,2,3,4,5,6,7” which… voila! Viola? Fixed it.

I set the page range back to 1-7, but again Print only displays 2-7.
I set the page range to 2-7 (was just curious) and Print displays 3,5, (blank page),7,2,4,6.
Weirdly, setting range to 3-6 displays in this order: 3, 5, (blank page?!), 2, 4.

Luckily I discovered the 1,2,3,4,5,6,7 trick and should be able to print. So glad I don’t have 88 pages._