Printed output does not match print mode screen

I find that I have to set to upper and lower page margins to 0 and the sides to 6mm in order to give me the 14mm sides and 1 cm top and bottom that I want. Printed output is then perfect, but the displays in Dorico all show things bumping right up to the edges of the page. I think I have changed all the A4 setting to US Letter (the paper I am printing on) but I am obviously missing something. There must be settings I haven’t done that would eliminate this kind of fudging. Any suggestions?

Maybe padding setting in the preferences of music frames?