Printing on Epson XP-6000

When i print with Dorico’s own printing capability on the right side, although i select “One side only” it still prints as duplex.

The “Duplex Printing” section is imo confusing. One one side it says “duplex printing”, which tells that it only supports duplex printing, on the other side it says “Print on” one side only, which in my case is not respected.

It would be more clear if “Duplex Printing” would have a switch to switch ON and OFF, and the provided features would only make sense if OFF is selected.

Is this a potential bug, or does Dorico only support duplex printing ?

Regards
Daniel

Dorico certainly can print on only one side of the page. You should find that provided you set ‘Print on’ to ‘One side only’ in the Print mode right-hand panel, you get printing on only one side. However, it could be that your printer driver has a duplex setting that is overriding the job settings that Dorico is setting. I would advise having a look at the settings in your printer driver to see if there are any defaults there that can be changed.

Everything looks correct to me. When i click on OS X Dialog’s Print… button i get it “without duplex printing”. When i click on Dorico’s Print button with Duplex Printing on set to “One side only” (this is imo not consistent because duplex and one side only are two different things), anyway it prints as duplex.
It could be that duplex is set to default somehow, but shouldn’t Dorico set Duplex to off when “One side only” is selected and not leaving it to default ?

I’m not quite sure what to suggest, unfortunately. I don’t have access to an Epson XP-6000 and I’m unlikely to be able to buy one to troubleshoot this for you. I encourage you to explore the defaults provided in the printer driver in case there’s a setting there you can change. Sorry.

For the record, it happens to me as well with a Brother HL-L2360D - Dorico will print as duplex no matter what I select. I haven’t found a way to change (or view) the printer default, but I’m pretty sure it’s one side only, as this is the way it prints in all other apps, including when I use the os dialog within Dorico.

It seems to me that it only behaves this way if I print over AirPrint. I haven’t had the chance to test it thoroughly, but it seem to work as expected when I use the USB port.

My Brother Printer has a dedicated utility app where you can set up its defaults. When setting it up, the duplex setting seemed to override the setting in the Print window (both Windows and Mac) if I remember correctly.
Perhaps you could check if there is some similar dedicated app for yours where you set it up initially, or a reset defaults procedure which presumably would default duplexing to single-sided.

Re-activating this thread, since I am experiencing a similar problem:

Duplex Printing: Print on One side only
OS X Print Dialog: Two-Sided off

Still, Dorico keeps printing on both sides when I use the “internal” print command on the right hand side of Dorico.

It is working though when I print from the OS X print dialog.

Using a HP Laser Jet M402dw with latest drivers

Try going to Printers & Scanners (within Settings), then select your printer, click Options & Supplies… Click the Utility tab at the top of the dialog, then Open Printer Utility. The HP Utility should load. From there click the Duplex Mode icon, and untick Enable Duplex Mode.

Does that work?

Yes, the settings macOS Print Dialogue will only be valid if you print through this route, as you have noticed.
Accessing the printer through it’s utility app will probably be the only way to change it’s default behaviour - as suggested by pianoleo.

thanks a lot for your answers. I already had unchecked the Duplex option in the printer’s utility. But Dorico keeps printing in Duplex mode when using the print panel on the right hand sinde within Dorico.

When using the macOS print dialog everything works fine, as you both suggested. So this is a workaround. But maybe this is something that should be taking care of in the next update.

thanks!

Unfortunately there are some settings on some printers that we can’t set directly. This includes the duplex setting on some printers, including the HP Laserjet we have here in the office. Unfortunately at the moment there’s nothing we can practically do about this.

Having what sounds like the same duplex issue with my HP Officejet Pro 8210 - despite setting “One side” in Dorico, “disable duplex” in the printer’s online config, all my parts are printing duplex using Dorico’s internal “Print” button.

Also, about 50% of the time if I print an odd-numbered single pages to make up what I need for a part using the internal “Print” button, Dorico crashes and prints a duplex copy of the whole part.

Using the OS X Dialog does correctly disable duplex for a single part, but still does not allow me to print multiple parts from one score in one job - the first part has duplex disabled, subsequent parts seem to have duplex enabled.

I’m afraid right now I don’t know what the solution is to this problem. Dorico is telling the printer to print on one side only, but it seems that the default setting for the printer is to print duplex, and unfortunately there’s no way to access the opaque options provided by the printer manufacturer in their own driver software from the cross-platform layer Dorico works at.

DanielLG, does this help in any way? (From the Epson XP-6000 manual)

I got the same problem with my new Brother HL-3152CDW

Would it be possible to get the more detailed macOS dialog for “Print…” in “Print View” from the bottom left like it is in the Apps Preview, Pages or Safari? I’m missing a preview and scale.
That would help because unfortunately printing from there scales the sheet down a bit for whatever reason… It does scale down by default in the more advanced dialog of Preview too, but there you can change it back to 100%. Right now printing is really awkward for me: Open the macOS-Print dialog, chose “Open in Preview” from the bottom left, adjust the scale to 100%, print. Printing one page is fine from within Dorico, but with more then one page I got that Duplex problem.

I am able to print to XP-6000 from the Mac quite successfully after exporting to PDF.

I have the same Brother HL-L2360D printer and can confirm what you say, one-side-printing via USB works fine here, too. The problem only occurs when printing via Airprint.

How is about the Epson XP-6000 printer, is on-side-printing via USB also possible here?

FWIW this recent thread also had (different) problems with the Airprint driver: https://www.steinberg.net/forums/viewtopic.php?f=246&t=154149&start=25#p831144

Thank you Rob, your hint was absolutely right, I followed the exact steps as Robby described and solved the problem :smiley:

It seems that it’s a good idea to select the driver of the respective printer manufacturer and not to use the default airprint driver, when setting up a printer via wlan for the first time, because this airprint driver obviously causes the problems with duplex printing.