Prior MIDI notes erasing after punch in

Hello All. I am a ProTools user out of necessity to be compatible, who has recently migrated to Cubase because of the benefits with midi, and many other reasons. On the newest version, and 10 Pro, after punching in manually, or automatically, in most cases one or two bars of midi prior to the punch in point are erased. Steinberg says they are unaware of this. It happens even with a blank session and no plug-ins and just one track. Is anyone else experiencing this? It could ruin our project and we would have to go back to ProTools. Would greatly appreciate any input. Thank you

1 Like

A repro would be helpful.

1 Like

I’ve asked a few times if you could try to reproduce it. It happens with your program stock, out of the box, with no additional preferences, plug-ins or anything. So I’ll just ask one more time: have you tried it yourself? Thank you!

1 Like

You have not asked me anything, actually.

Please, in the format requested so the related settings are known. There’s no other way to reproduce your issue.

1 Like

Sorry, I was referring to your company and the other support method by email. I keep asking them to try it on their end.

It’s very simple. When you punch in MIDI with the record button, and you’re finished with the recording, it erases a bar or two prior. But OK I will look into what you are requesting

1 Like

If that is really all there is to it-- sorry, can’t reproduce. Works normally here.

Note that Steinberg employees are identified by the logo in their profile.

1 Like

Wow. Ok. So then it just be something with the iMac Pro and Sierra or something on the computer aide because it was out of the box so to speak.

To confirm: while an existing midi performance is being played by Cubase, in the middle of it, you press record in the “replace“ mode to punch in a part.

You play a few notes, then you disengage record. This is what you are doing, correct?

And you are saying that when you do so, it does not erase one or two bars prior to the punch in point. Correct?

1 Like

Here’s a video in Cubase 11, no problem. I no longer have 10.5 installed to test this but as far as I remember I didn’t have problem with this. If you need further help message me, I’ll be happy to solve this for you.

Thank you very much for taking the time. I couldn’t see on my iPhone but is this in “replace“ mode? all the same parameters I described below?

Also on the Halcion synthesizer, the scrolling of the names of the instruments all converge together. They are unreadable unless you move the mouse around a lot. The GUI is not working well. Just telling you in case this is another barometer of something wrong with the OS. Or a conflict somewhere. Have you heard of this?

Lastly, my understanding is that you want me to send you all the details of my computer according to the format you mentioned. Correct?

1 Like

Is there any way you could change my mail email address and account to:

[xxx] ?

I don’t work for steinberg… :joy: I’m a user like you trying to help you…

1 Like

Okay I took another video for you showing that I have replace on.
Video num.1

Now in the second video I’ve clicked/press record with “replace on” the event that you’re talking about happens because you’re confusing cubase because you pressed record (that means you’re telling cubase you want to record) you should press play instead in this case so this doesn’t happen to you! And then cubase automatically turns record when it gets to the PI PO you’ve set - or for most people the loop area (I like them to be set separately).
Video num. 2

Yes, sorry. I figured that out from our conversation. I appreciate it.

Thanks. Can see yours works. Using an iMac Pro 2018, and High Sierra 10.13.6

Sorry, I’m not understanding. Here are the steps I take. A few questions to make sure I’m understanding you:
1- I press play, then when I want to punch in, I press record. So I do press play first.
2- Are you saying that I should use the AUTO PUNCH (ins and outs)? If so, I believe I tried manually punching in and auto.
3- I told Cubase support about these exact steps, and they said there is no known bug
4- Were you able to re-create this issue when pressing play, then record to punch in? Or is this an assumption?


PS: and PRE ROLL was not on. So why would Cubase get confused when I hit play, then record moments later to punch in? I have Pro Tools, Sequoia, and Logic here and they have no issues. Cubase punches in audio without any issues, so I want to make sure I’m understanding you. If I understand correctly, you’re saying Cubase CANNOT punch in MIDI on the fly, with the record button. Correct? Thanks.

I tried punching in automatically (I and O) as I do sometimes, as you suggested, and the issue is resolved. So I will just use I and O. Thank you. I have another issue regarding pops and clicks and lagging audio. Will post with different subject.

I was recording piano midi parts using Cubase as a tape recorder and I was ignoring bar lines, tempo and quantising. This was fine until I had the problem of midi being erased prior to the drop in point. If I wanted to drop in at the middle of a bar which was not in fact any kind of bar(!) it would erase any notes between the preceding bar line and my drop in point. The drop out was fine. The problem was solved with the helpful videos posted above which was using sequenced data and getting the same problem for a different reason. However, this made me realise it was the bar lines that were the problem. After that it was easy… just change the project to timecode base!