privileged helper has wrong version

Hi,

I ran the updated to Cubase Pro 10.0.40 and when it gets to the additional content part of the install I get a popup window that says "Trying to install privileged Helper Tool. Please enter password.

I enter my MacOS password then get an error pop-up: “Steinberg Library Manager privileged helper has wrong version (-1,-1). Failed to establish privileged helper! Please get the latest Steinberg Library Manger and reinstall!”

So I download the latest version of the Library Manager v3.0.23 Build 206, and install. That goes ok. But then if I select any library in the Manager and click “Move”, I get the same pop-up error (see attached image file)

I contacted Steinberg customer support and we emailed back & forth a few times. The last response was that the service tech was “sending this up the food chain to see what they can discover”. Haven’t heard back yet.

Cubase works. I haven’t tested every single soundbank but my projects seem to be ok. But I do want to offload these sound libraries from my internal SSD to an external Thunderbolt drive.

Things I’ve tried:

  • First Aid in Disk Utility
    Manually change permissions on the /Library/ApplicationSupport/Steinberg folder to include read&write for my User Account.
    Reset/Verify permissions command from Terminal
    Cubase Update only file 10.0.40
    Search this forum
    Try running the Halion 6 installer v6.3 (same error popup when it gets to installing the content)
    Remove Cubase and run Cubase Full Installer 10.0.40

MacOS Mojave 10.14.6
Macbook Pro 15" i7 Radeon M370X
512GB SSD
Thunderbolt 2

Hi JayinTech,

identical problem on my side. The problem first came up with the update to 10.0.40.
Got the same popup windows. The library manager ask for the password and then the message “Steinberg Library Manager privileged helper has wrong version (-1,-1). Failed to establish privileged helper! Please get the latest Steinberg Library Manger and reinstall!” pops up and content does not install.

I was hoping 10.5 will cure the problem but the same behavior happened during installing 10.5 update.

Then I completely removed Cubase 10 and tried an install from the fuzll 10.5 download – unfortunately same problem remains. Now Cubase is installed without any content.

Tried to fix permissions, update Halion 3 SE (same error), reinstall Library manager, new install from full install.

Steinberg customer support did not answer ticket (yet).

Any idea would be much appreciated.

Helmut

MacOS Mojave 10.14.6
iMac 5k 2017 i7 Radeon Pro 580
3TB Fusion Drive

Yep!

Steinberg Library Manager 3.0.24 is a no go.

does not work…moving, removing…they all render this error - the privileged helper doesn’t work - at least in mac osx

The quick fix is to revert to using Steinberg Library Manager 3.0.23 or even Steinberg Library Manager 3.0.22 - which both work perfectly.

Be warned - the Padshop Pro 2.0.1 update also installs this buggy .24 Library Manager, you have to delete it from your apps folder
and install 3.0.23 again to get any functionality.

The previous versions do not appear to be in the FTP archive… but i kept a backup (of course), you can message me if desperate!

Hi guys,

@Quantize - I am not able to send you a private message here (no idea why). Is there any way you could share v 3.0.22 or 3.0.23 Library Manager (for MacOSX) with me? My e-mail is pin18@wp.pl

Hi,

please make sure that you have the latest Steinberg Library Manager installed:
A separate Download is available on the following website:

https://www.steinberg.net/index.php?id=14708&L=1

If the issue should persist afterwards please let us know which version of macOS you have on your system and if you have any additional antivirus, maintenance (ie. mackeeper etc.) or firewall software installed.

Cheers,

Jan

I too have that problem and it persists even when I have downloaded and installed latest version.

I bought the Absolute collection a couple of months ago. Can’t even install it. :unamused:

Same problem tonight as i’m installing the 10.5.10 update, can’t finish the install (update of vst sound folders).
i’m on mac with catalina 10.15.3

Same here… Installed latest version (mojave 10.14.6)

same here. Update is Fubar. I can’t believe Steinberg hasn’t fixed this since 10.0.40

Hi,

We are very sorry to hear that the issue persists on your systems.
Unfortunately we are unable to reproduce the issue on any mac in house, so we need to ask your for some manual file management.
The installer should usually clean up any old helper versions and replace them correctly.
Please delete the following files by hand, to make sure that they can be reinstalled:

/Library/LaunchDaemons/com.steinberg.HALionLibraryInstallerHelper.plist
/Library/PrivilegedHelperTools/com.steinberg.HALionLibraryInstallerHelper

Afterwards restart your computer to make sure that there is no open program blocking the files.
Then reinstall the Steinberg Library Manager with the installer from this page:

https://www.steinberg.net/index.php?id=14708&L=1

As stated above, you need to ensure that there is no interference by anti virus or maintenance programs (onyx, mackeeper etc.)
If the issue persists afterwards, please get in touch with our support department by opening a regular ticket.

Cheers,

Jan

Hi Jan
The library manager issue is with me too, yet.
I had tried to follow your guide and My ELC is latest version, but not solved.

I had bought the expansion “bouncy vibration” but can’t be installed.
can’t be installed Cubase 10.5.10 pro, either.

How can I do?



My PC & OS
iMac 2014 i7 4G 32g
macOS 10.14 Mojave (latest)
Cubase 10 pro, 10.5 pro

Best,

I already tried removing both of those system files mentioned and installing fresh, but still it did not work. Dorico 3.1 also cannot install now even though previously it did. Well the app installs but no content is installed

Hey,

Getting exactly the same thing. Tried everything in this post. but still get the error. it’s very irritating!

I have the same problem: I’ve tried the two versions of the helper program on the Steinberg website, threw out the library files, cleared caches, all to no avail.
Irritating.

Same thing here trying to install any library I bought from Steinberg and also the 10.5.10 Cubase update.

EDIT: I wonder if anything to common to all of us if Steinberg can’t replicate it?

I’m using library locations that aren’t default - so mine are on an a hard drive other than the root drive.

cough

I tried to delete the two halion files, restart & re-install but it can’t finish the last part. Still the same issue… :frowning: annoying…

I have performed these steps, re-installed the latest library and cannot install RAST-A and a bunch of Groove Agent libraries I bought in the recent sale.

I’m on Mojave 10.14.6 - this is the first time in the history of using Steinberg (around 25 years) that I’m quite annoyed because I’ve purchased a whole bunch of stuff that I can’t use.

I’m not doing anything wrong, and I’m not a newbie with computers or a newbie to using and managing Steinberg libraries.

It also prevents all the libraries installing from the latest 10.5.10 Cubase update.

This is a bug - a decent one, and it’s impacting my very busy studio.

throwing out the latest Steinberg Library Manager(deleting from Applications) , downloading Steinberg Library Manager 3.0.23 via this page:
https://www.steinberg.net/en/support/content_and_accessories/steinberg_library_manager.html

Scroll down a bit on the page.

Open it. Keep it open. Launch Steinberg Download Assistant and installing the Retrologue content worked for me. Sequence presets are back.

Hope this helps.

This WORKS.

So version 3.0.23 opens, I can suddenly see all of my Padshop libraries (perviously only default library was visible) and also I’m able to import the recent purchases that I made.

Something is up with 3.0.25 I’m afraid.

Thank you @zipb