Pro 8.5 and 8.5.1 -odd audio spikes. Suspend VST


Well as much as I can get in is already in the title. This isn’t a bug, but a behaviour following updates.

I started to notice that whenever switching to mixer view (f3) I was hearing some audio spikes. It seemed worse on bigger projects and has been a nuisance. I also started to notice that a few of my Preferences had changed.

So, this is a heads up in case you have similar problems. Spikes occurred only when switching to, not from mixer, didn’t happen in simple first draft projects, only once I had plug ins in use.

The cause was a change in my preferences ticking the “Suspend VST3 processing…” ( >Preferences>Plugins). Unticking solves my problem and eliminates performance spikes too. That’s a logical explanation for my problem.

But, searching around since, I have found at least six other unwarranted changes to my settings, such as MIDI reset on stop for example. All things that are hidden in the detail. Most of my prefs are still set.

This only happened to me from Pro 8.5 onwards, so I guess that my settings have been subtly corrupted. I have worked my way through resetting things as they should have been and bingo, my system is back to running strong and sweet. It’s quite a relief as I felt that I have been taking a performance hit on recent updates.

I hope this might help other people - my first guess was a graphics issue, which I was chasing around without any success at all.