[Probably solved in 10.5.12] Massive CPU overload in 10.5.1 (but not in 9.5.40)

I had hoped that .5.10 would cure this, but I am still getting massive CPU overloads when inserting, moving, turning on or off, or deleting plugins. The real-time meter goes to max [avg. load], and Cubase hangs for 3-30 seconds. This does NOT happen in 9.5.40, with the exact same projects. Something has obviously changed between the two versions (I skipped 10.0), and not for the better. If I increase the asio buffer a lot (1024+) the problem is less severe, but it really shouldn’t be neccessary.

Edit/update: it seems to not be actual CPU overs, the system monitor shows no spikes on any cores, physical or virtual. This is simply Cubase choking on very simple plugin changes.

Edit/update2: After having struggled with this for weeks, I finally caved and went back to 9.5.40. Despite the less colourful interface and missing features, the creativity is now back on track. I’m eagerly awaiting a usable 10.5.x.

j,

Similar thing here, although with me it’s the average load, not the4 peak.
As soon as I insert/mode/remove plugins or add a send, the average load goes to ~100 and Cubase becomes unresponsive and stutters audio playback.
The project usually has around 50-60% avgload.

In 10.5.10 it is really bad, it can take 10 or more seconds until it recovers (or sometimes even doesn’t and I have to reopen the project). Pretty much unusable.
In 10.5.0 it is a bit better, but still get a short spike of avg load to 100 and audio stutters, but maybe just for 1 second.

Windows 10, latest patches. RME Fireface UCX with current driver and firmware @256 samples buffer.

Things I tried but didn’t make any difference:

  • Updated BIOS to latest version (ASUS Z370A with i78700K CPU)
  • enabled/disabled “disable VST3 plugin processing” option but to no effect.

Also no spikes on the CPU usage itself, it stays constant even when Cubase is completely unresponsive.

For this scenario I would actually open a case with Steinberg, but I learned by now how completely futile an exercise that is…

This is a new feature. Supposed to be fixed with next update, yada yada

Yes, it’s the avg. for me as well. I didn’t phrase it well, by “real-time meter” I meant the one that shows the constant average load. :slight_smile:

j,

Hmm, no going back to 10.5.0 didn’t fix it completely, still have the effect mostly with projects that have an average load >~60% and when e.g. opening some plugins.

Can 9.5 open project saved with 10.x?

Yes, but the new features will be missing, of course.

j,

Hi

I’m having exactly the same behavior the OP is having. Removing or adding plugins or tracks completely chokes Cubase 10.5.10 with a relatively large project (performance meter average at around 80%). Bypassing and then enabling every plugin (alt click in top of mix console) solves the problem and Cubase regains the ability to play this project, but it’s basically unusable as is, since playback is so sensitive to dropping out.

Also a very light project (average around 10 %) occasionally has similar chocking for a couple of seconds when doing similar changes.

None of this is happening in 10.0.50, which is what I’m forced to use for now…

Hopefully this get’s a fix soon. :slight_smile:

Edit: Forgot to mention that I uninstalled 10.5.10 once and reinstalled from the full installer (also choosing to reinstall “components”), didn’t help… :unamused:

One more thing. I just tried trashing the preferences, and it improved the situation a little (not enough though…). Before trashing the prefs. my real-time peak performance was also through the roof. Now that’s nice and low, but the same chocking of playback is still just as easily triggered…

Also I noticed a big change in windows task manager after trashing the preferences. Earlier this bigger project that I’m currently testing with utilized heavily a single core (of 10). Now the load is very evenly spread on all cores. But yeah, didn’t help at all with the real problem… :unamused:

One final test: I reinstalled 10.5.0 and it behaves just as bad for me… That’s enough troubleshooting for now… :stuck_out_tongue:

Definitely seeing this too with the same symptoms!
Windows Resource Monitor doesn’t show any major CPU spikes, yet Cubase does, and in turn, it freezes, audio stops. When you stop the playback, you literally wait for a good few seconds before you gain control.
Perhaps the threshold on Cubase for CPU usage monitor is not synced to the actual CPU available, so we experience this problem.

I might re-install from scratch but since others have done so already, i doubt it’ll make a difference.

Was supposed to be fixed with 10.5.10 but clearly isn’t:
https://www.steinberg.net/forums/viewtopic.php?f=286&t=178016
I also don’t find anything regarding this in the release notes. I’ts mostly about Mac performance issues, but this is on windows for me…

I think it is actually a bit better in 10.5.0 here. I created a test project with 120 instances of MJUC, up to a load of ~75%, and there’s a bit of a stutter when adding plugins/send, but Cubase was never dropout-free when doing that. Seems OK-ish.
A real life project behaves much worse, even though the load is lower.
So it might actually be specific plugins, but that doesn’t help.

I’m glad I am glad I am not alone in this. This needs fixing now!

I’m not 100% sure that the issue described there is the same. That one is VST3 related, and could be fixed by turning off the “stop processing VST3 when silent” or whatever it’s called. The present one is VST2/3 agnostic and has no apparent relation to the “don’t process when silent” tick box. If I’m guessing, I’d point a finger at the new core load scheduler that was introduced to make better use of 6+ cores.

Ftr: I’m not getting this on my mobile setup, which is a quad-core with the exact same GFX card as in the studio (GTX1050). [EDIT: I DO get it on the mob system too, but the “hangs” are much shorter (1-4 secs) than in the studio.]

j,

+1

https://www.steinberg.net/forums/viewtopic.php?f=283&t=181020#p961210

I am curious for Win 10 users if the MMCSS optimisations/issues have anything to do with this for some users, as outlined in this DAWBench post:

https://www.facebook.com/dawbench/posts/408325346541888

That is definitely interesting, and in parallel with my guess that the problem may be connected to the core load distribution. However, my studio machine is a hex-core, which means that it shouldn’t be affected at all :slight_smile: Otoh, perhaps the under the hood fix isn’t working very well, causing the max-out.

j,

https://www.steinberg.net/forums/viewtopic.php?f=34&t=181345

!

We’ll see in a couple of hours if it works :slight_smile:

j,

The issue was in the ASIO Guard / prefetch area.

It was not connected to the amount of cores: despite previous Cubase versions were not able to make good use of the virtual threads, the limitation was 32 cores since Cubase 5 and has been lifted in Cubase 10.
@Atardecer: ASIO Guard has been introduced to make use of the virtual threads, currently it is the expected behaviour to see Cubase use half of the cores with AG off (virtual threads will be unused in this case).

Hope the hotfix works for all of you.

Kind regards,