Problem controlling the transport with Generic Device (8.5)

:frowning: I think I set up everything perfectly … MIDI messages are coming into the DAW (and into the dialog via “Learn”) - but nothing happens with the transport …

Help please?!?

Thanks!

Hi,

Are you sure, Play is using MIDI Channel 1 and the other commands are using MIDI Channel 16? Also the MIDI CC numbers look inconsistent.

Does at least one button work?

The MIDI channels are correct. (I “leaned” them.

The CCs were me trying to find replaceable addresses.

None of the buttons work.

It used to work with this device - but I reinstalled on a new computer and need to set it up again.

Hi,

Could you verify the MIDIMessages by using MIDI Monitor, please?

Yup (already did that)

image

Looks good

The CH is 2 because I am on a MIDI channel,

I changed the channel to CH 1 and it changes accordingly

Hi,

Change the track’s Channel to Any, please. I also don’t see the MIDI Message CC18.

I did that and they are all CH 16 .

The Play setting was wrong… I re Learned it and this is the correct assignment

Transport still doesn’t respond

Is this OK?

I mean … the controller is sending CC to the channel - it shouldn’t be like that if I am not mistaken.

Hi,

Yes, this is OK.

Don’t you use these MIDI CCs as any of the Quick Controls?

I used to use it for programming MIDI CCs for various internal and external devices - so I kept it free-flowing MIDI.

Now I have another controller so I might use it as QC…
(If I remember correctly, setting it to QC didn’t allow me to use these CCs as regular transmissions…)

Any idea what could be the problem?

Hi,

Could you attach the screenshot, please?

Don’t you have to set the Flags in the upper area to “R” to indicate “Read” ?

1 Like

DOH!!!

I tried that - but it was on the wrongly configured parameter…

Thanks! It works now!

1 Like