Problem: Installation of Steinberg UR44 Applications

I’ve just bought the UR44 and was very eager to give it a go with my newly bought Rode NT1-A.
The Yamaha Steinberg USB Audio Driver and BasicFX suite plugins have been installed just fine.
However, I’ve encountered an issue during the installation of the Steinberg UR44 Applications (dspMix etc.).

All the active processes in my Task Manager prior to starting the installation.

These are the errors that rolled back my installation.

I’m operating on Windows 8 Pro (64-bit) and The Tools for UR44 that I’ve downloaded are of the latest version, v2.1.1.
Althought I’ve tried “Run as administrator” when running the setup.exe and disabling the Windows Defender, I’m still getting those pesky errors.

Any help on the matter would be most appreciated. Cheers.

I’ve tried installing everything on my friend’s laptop (Windows 7 Ultimate 64-bit) and it worked perfectly.

I really thought it’s because my SSD is low on storage space so I cleared up some space by uninstalling the eLicenser and BasicFX Suite. Apparently that didn’t fix the issue at all. I think it’s just something wrong with my Windows.

Like I’ve said, any insight into the matter will help me greatly. Please comment if you have read this thread. Thanks.

Not a single reply after so many days…sigh…

I guess I’m just going to talk to myself and try and resolve the issue myself again then…I’m going to replace the 40GB SSD on my laptop with either a higher capacity SSD or simply just put back the original 693GB HDD and install a clean copy of Windows. The question: should I stay with Windows 8 Pro or upgrade it to Windows 10 since it’s still free to upgrade at the moment? Pros and cons…What a hassle…

Hey there, did you ever get this resolved? I’m having the same exact problem with the UR824 after upgrading to Windows 10. Any help would be greatly appreciated.


Hi Matt,
I’ve managed to get the applications and drivers working on both my mum’s Windows 7 laptop and my own Windows 7 desktop. It doesn’t work straight away. A restart is required before the device is being recognised by the OS.

If you’re asking if the drivers and apps work on Windows 10, sorry, I couldn’t help you with that yet because I haven’t upgraded my laptop from Windows 8 to 10. I’ve just installed a new 120GB SSD into my laptop so I have yet to get everything working in proper order.

Will keep you updated if I ever upgrade to Windows 10. Cheers.