Problem recording from two sources - Latency

Hi All

So, I am using Cubase 12 Elements and am trying to record from 4 inputs at the same time, two are the computers own Line in and the others are a NI Komplete 6 1st gen.

I can set each up to work perfectly on it’s own but when I combine them I get about half a second of latency. If I use one or the other my latency is below 5ms but together it’s over 500ms but the latency shown in the Studio Setup => Audio System is 11ms.

I’ve tried dropping the sample rate to a very low setting and the latency is still the same (+500ms) using the ASIO4ALL driver.

I also get the 500ms delay when recording any of the inputs.

The thing is it works perfectly on Reaper (Sorry for the heresy) and the same ASIO4ALL drivers. All four mono inputs work with a very low latency and higher sample rates so I am assuming it’s something in Cubase 12.

Could someone please point me in the right direction.


No one?


I think most people use an external ‘Audio Interface’. You seem to be using the build in soundcard, which could be a reason for latency. (These devices are usually not ‘top quality’ AD/DA converters)
You say to be recording ‘from two sources’. Okay but:
The computer’s own line input is ‘audio’.
The NI Komplete does not produce sound, so there you are recording MIDI. The sound you here is generated by a Sampler or synthesizer running on your PC.
Can explain what you see in the ‘Studio > Studio setup’ window, under Audio System?

Have you read the manual for ASIO4ALL? Maybe you can find something in there to be of help to you?

Additionally: look for any plug-ins in Cubase. We had several people here reporting latency issues only to find out that a deactivated plug-in caused it.

As I said if I just use one the latency is good, either the external USB interface or the PCs own line/mic in. They give about the same, around 6-8ms.

Actually it has 2 mono audio inputs, which I want to use as stereo, and Midi, but I am not using midi.

The problem is when I use both together, and it’s fine on another DAW but I want to use Cubase 12.

A picture is worth a thousand words

Wouldn’t that cause an output latency issue? Or an issue when I use only one input as well?

What you hear is always the combined latency (in + out). As you stated the audible latency is not reported in Cubase. Therefore you don’t need to worry whether it is input or output latency.

This is an example where a deactivated plugin adds 109ms latency.

Of course, But I thought you were new on the forum and not yet ‘allowed’ to upload screenshots.
The latency shown on the screen looks ‘good’.

So you use the NI Komplete as a ‘soundcard’. (correct me if I am wrong). Have you configured this in the ASIO4ALL as an ‘aggregate’ combining the built in- with the Komplete interface?

This is the ASIO4all setting, if I lower the offset too far I get the audio breaking up.


Each on it’s own is good but together they have about 500ms latency, but that doesn’t show in anywhere in Cubase and it’s fine in Reaper, but I don’t like it that much.

Oh sorry, there are no plug ins on the channels at all. No active and no deactivated. Inserts is a list of empty boxes.

The output I use is the Komplete with the Direct monitoring off.

One more thing, the Audio performance doesn’t get above 25%.

Edit: I just connected my Pod XT via the USB and the lag doesn’t change. So 6 inputs doesn’t change it.

As far as I can tell, this is an ‘unusual’ setup (and far from optimal).
I’d check if the sample rate for the Realtek HD matches the Komplete Audio. (And I suggest trying 44K sample rate).
Good luck!

I tried lowering the sample rate and the buffer size, it didn’t help.

Thanks for the help.

Make sure to match the sample rate in the Windows settings:

You can get there through the old Windows’ System Settings → Hardware & Sound → Sounds → Manage audio devices → Recording (and Playback)

Sorry for the delay, I matched the sample rates in Cubase to the sounds number and no change.