Problem Recording Midi in Cycle Mode

If I have the song playing, cycling round a section of bars, then hit record, the notes I play are not recorded correctly. Either they don’t get recorded at all, or they all have negative lengths. I’ve attached a screen shot from the List editor to show all these negative-length note values. (I was in Merge/Mix mode, so you see regular notes too.)

Has anyone else had this problem with less-than-zero-length notes? They manifest as a “midi splat” where all the notes are played simultaneously on playback.


Could you try in Cubase Safe Start Mode, please?

OK, I did and now it works fine. What does this mean? Which setting is the corrupt one?


Hard to guess what is wrong. It could be any preferences. If you don’t have too much Cubase customisation, I would recommend to delete Cubase preferences.

I have a lot of customisation.

Can this be logged as a bug then? There are no circumstances as far as I’m aware in which a note should have a length less than zero

That would require the “bug” to be reproducible.
Sounds more like your preferences have been corrupted.
You could pull the preferences from an backup, when it was working.

You could pull the preferences from an backup, when it was working.

Failing in having a pre-failure backup copy, you might try this: Open your Preferences menu and screenshot each menu so you have a visual record of your customizations (there are other menus that have settings besides Preferences…so screenshoot them as well). Once done, make a copy of your current Preferences folder and move it to your desktop. Delete the original folder and launch Cubase. If the problem goes away, start dragging files from the copied folder back into the original folder and reboot Cubase with each addition until the problem occurs again. Then you’ll know which pref was corrupted. At that point, you can delete the Preference folder and drag everything _but_the offending pref from the copied folder into the original and have _most_of your prefs restored. Yes, an annoyingly lengthy and tedious process.

The less tedious variation to this is to delete the original prefs folder and launch. if the problem is gone, refer to the screenshots and reset the prefs from them.

Thanks for the suggestion. I might raise a ticket with Steinberg to see if they have anything to say on the subject. Notes that go backwards in time just shouldn’t be a thing :wink: