Problem Recording MIDI make a double long notes or just double

Hello, I have a problem on NUENDO 13 when I record MIDI for about 2 weeks. When I record or do a retrospective recording, NUENDO creates duplicate notes for me. There are 3 forms of duplicates.
1- Very long notes of the length of the container or locator OUT
I delete the long notes and only the notes played normally remain.
2- Very short notes with 0 ticks just in front of the note played
I have to select them to remove them.
3- Almost identical duplicates
Removing duplicates does not remove all of them as there may be slight differences in duration.

I haven’t changed anything in my MIDI settings and my keyboard (YAMAHA CP33) and it is not in SPLIT MODE. I’ve been working in MIDI for 30 years on Cubase and Nuendo and I’ve never had this.
Do you have an idea ? Maybe since installing NUENDO 13?
I don’t know…
Thank you Olivier

Hi,

This happens, if the Timestamp is not transfered correctly.

How does it look like in the MIDI Monitor MIDI Insert, please? Are the MIDI Note Events red, or do they have the common color? Is there any hint information in the MIDI Monitor?

Are you on Windows or Mac, please?

How is the CP33 connected to your computer? Do you use USB cable, or do you use MIDI cable connected to any other MIDI-USB device (which one)? Could you try another USB cable or another USB port?

Hy Martin, I use MIDI cable connected in RME UFX MIDI IN. And that for many years.
it appeared suddenly. I’m in Widows 11.
The MIDI Monitor is RED but seems to work. I do not look at it often so I don’t remenber the common colour. I will test another Port or Cable tomorow or maybe try an USB if I find a long one. Any idea ?
Thanks anyway

Hi,

This indicates the Timestamp issues. The common color is white (or light-grey).

Make sure, you have the latest RME driver installed, please.

You can also try to enable the WinRT MIDI Driver in Cubase > Studio > Studio Setup > MIDI Ports Setup.

1 Like

I was having a similar issue, so I switched to the WinRT MIDI Driver and system timestamps, but to no avail. After some investigation I discovered that I had inadvertently changed the velocity curve in my keyboard at some point, causing Note-Ons at velocity 0 to be transmitted at the lightest dynamics of playing. While recording, these notes just wouldn’t register, however when stored in the retrospective record buffer they would be interpreted differently as either slight stutter notes before a longer held note, or extremely long held notes that extend for a while, overlapping other parts of what was played. For me, changing the velocity curve has thus far eliminated this issue.

1 Like

Hi @Semarus ,

This is interesting. Do I understand you correct, Cubase doesn’t handle correctly MIDI Notes with Velocity 0?

Well technically they would be Note-Off, but from my understanding Note-On at Velocity 0 can be interpreted as different from Note-Off and have a practical function that way, but I’ve never used MIDI to that extent. In any case, I think the takeaway is that Cubase/Nuendo handles it differently when Recording vs. storing in the Retrospective Record buffer.

Hi,
I finally make some tests.
To change the Input selection —> same problem
To change the MIDI Cable and the MIDI INPUT on RME Fireface UFX —> same problem

And Finally to install USB Yamaha Driver for my CP33 for USB MIDI
And It Works !!! :slight_smile:

It seems to be resolved, but I don’t still know why I have this problem with MIDI connection and cable. Is it the MIDI Interface of the Piano, or The RME MIDI ???
Is it the Update 13.0.30 that I installed witch have a provblem with my piano and MIDI interface ???

So it works, thanks for your help and back to work and composition !
I suppose I will never know !!!

2 Likes

Hi,

If I understand you right…

  • If you make the MIDI connection to RME and via USB to the computer, then the issue happens.
  • If you connect it directly to the computer via USB, then it works with no issue.

Am I correct?

No Martin, I just changed my way of working from MIDI cable to USB to get around the problem I was having with the MIDI cable. I’ve never used the two together.

The problem is still here if I use MIDI cable (of course without USB MIDI)