Problem setting up ur22 for guitar

Hi! I think I’ve missed something, cause I cant´hear my (software-) effected guitar sound thorough my ur 22. Using Macbook pro and carageband and guitar rig -demo. I changed driver both in computers preferences and in Garageband to Steinberg. Only I can hear is the uneffected sound. Using the 2nd input Hi-z selected. Could I have broken the device with too much gain? Otherwise sounds thorough ur22 are OK.

Is the “mic” of your UR22 button turned at the “Daw” position ?

Yes, at DAW -position I can´t hear anything, on the other end “input” -position I get clean guitar sound as it should be. Maybe the problem is at garageband intstrument settings for track, that I cant´t get right?

You have probably miss something in the setup of Garageband.

It’s pretty simple, once you have plugged the guitar in the UR22 input 2 with HiZ engaged, a correct input gain, and the “mix” button on the DAW position, you have to change some parameters in Garageband :

  • in garageband preference choose UR22 as input and output device
    1.jpg
  • click twice on the amp picture to see the amp settings.
    Choose “Mono 2 (steinberg UR22)” as source input and activate “control”, you may have some input signal in the guitar track and you may hear the amp guitar sound in your head phone plugged on the UR22.
    2.jpg

Hi! Thank’s for advice. I managed to figure it out myself and that was exactly as simple as you wrote. Thank’s also everyone here who thought about my problem.