Problem: switching between 2 voices in one staff / LA Studio

Hi everybody:

at the moment I’m working on Schubert’s Impromptu op. 90 no 4 (Ab-major)

In both staffs there are 2 voices (left/right hand) and input is via MIDI.

I put in the first 80 bars and used “SHIFT-V” to establish the 2nd voices and everything was fine.

After opening the file I tried to continue. Problem is: I can only put in the 2nd voices by pressing “SHIFT-V” again, but Dorico then establishes a 3rd voice.

If I try to switch between voices with the little note (stems up/down) under the carot line and put in the 2nd voice, the first voice is overwritten with the 2nd voice.

If I try to switch by the little number under the carot line, the stems of both voices are either completely up or down.

Can anybody tell me what I do wrong and explain the proper use of handling 2 voices in 1 staff?

I`m looking forward to your answers!

Problem No 2:

I created an empty file using the YAMAHA PIANO… from HALION with 60 empty bars and use that as “input mask”.

Each time I open it, I get the message “Cannot locate Impulse Response File LA Studio. wav”

I know this problem is already discussed in the forum - the advice was: “Reinstall the sound files”.

I did it twice and then deleted Dorico completely and reinstalled everything - but this problem still consists :frowning:

Again I’m looking forward to your answers :wink:



  1. Once you’ve established a second voice, just use “V” (not Shift-V) to switch between voices 1 and 2.

  2. No idea - somebody cleverer will be along shortly I’m sure.

Thnx for the quick reply, pionaleo :wink:

It works, but I put in the 1st voice first. When I use “V”, the 1st voice changes the stems to “down” and the 2nd voice has stems up.

Do I have to keep an eye on the “input order” of the voices: first put in the 2nd voice and then put in the 1st voice?


No, Dorico is eminently flexible; you can input voices in whatever order you like, and cut and paste from any voice to any other voice.

Is there any possibility you’ve either:

  1. Input your first (stems-up) voice using a downstem voice?


  1. Manually flipped the stems of anything?

Regarding 1., in Dorico voices are set as either listen voices or downstem voices, but the assignation doesn’t really come into play unless you’ve got two voices or more on a staff.

There are various quick fixes that you could investigate. In terms of selecting just the voice you want to alter, there are useful filters on the Edit menu, under Filter Voices. Once you’ve got stuff selected you can right click and change the assigned voice.

Since voices are usually added in a standard order, it might be helpful to know what the color of your upstem and downstem voice are.
(Set via Write Mode > View > Voice and Rest Colors.)

For the LA Studio warning, you could try resetting the audio engine’s internal cache so that it rebuilds its database. Follow the steps in the FAQ to delete the VSTAudioEngine data directory:

it’s me again.

after checking your advice, dear colleagues, (thnx a lot!!) here my experiences:

If I enter the lower voice (stems down) first and the upper voice (stems up) later, I get the best results.

In the Schubert piece (3/4 measure), the left hand the lower voice sometimes has a crotchet on beat 1 and above 6 eight notes.

For a few bars my above mentioned strategy worked fine - that means, that Dorico made a crotchet stem down and melted it with a eight note stem up -
1 note with 2 stems up and down - as written in the original notes without unnecessary rests!!

Suddenly Dorico changed its strategy - the crotchet and the eight appeared next to each other - 2 notes on beat 1 not melted - and the rests of voice 1 and 2 are displayed on the staff.

I don’t know why, because I didn’t change my workflow…

Hey boys at Steinberg: You certainly do a brilliant job, but can you please have a close look on your algorithm that deals with this problem?

@ PaulWamsley: I deleted the VSTAudioEngine data directory 3 times - as I mentioned above, this phenomenon was discussed earlier in this forum -after having rebooted, the prob seemed to be solved. But after switching on the computer a second time, the prob was there again.

Any suggestions?



Peter, can you either post the file here (you’ll need to zip it or the forum won’t accept the attachment) or even just post a screenshot of what you’re having problems with?

I’ve engraved literally hundreds of pages in Dorico and I’ve never had any problems with the specific algorithms that are at play here.

Just in case this is helpful, I’ve typed up bars 71-79 or thereabouts, which are the first instance of multiple voices on one stave. The only things that aren’t default are:

  1. Slurs set to begin at the end of tied notes.
  2. Tuplet numbers are hidden after the first couple of bars.

Modelled on what looks like a Dover reprint on IMSLP here:,_Op_90.pdf
schubert (281 KB)

I’d still like to know what color the voices are; I think he may have switched them part way.
(I’ve done that myself in the past.)

Here a pic of my problem
Schubert op. 90 No (17.4 KB)

Can you attach an image with voice colors enabled? You’ll find it in View -> Note and Rest Colors -> Voice Colors.

Yes, of course!
Schubert voice (24.7 KB)

There’s your problem. The eighth notes in the second bar should be in the same voice as the upstem notes in the previous bar (bluey-greeny-turquoise - probably upstem voice 1) and the quarter note in the second bar should be in the same voice as the downstem notes in the previous bar (purple - probably downstem voice 1).


what do I do wrong??

Yours Peter

Better: How can I avoid having so much colors (voices)

Thnx a lot for your engagement!!!


As you said in your original post, you’ve been used Shift-V every time you want to change voice.
By default, each stave has only one voice - upstem voice 1
If you type Shift-V you’ll get another voice - downstem voice 1
From there onwards you should be able to just type V, not Shift-V, to switch between these two voices.
If you need further voices, type Shift-V and you’ll find that you get upstem voice 2, downstem voice 2, upstem voice 3 etc. etc.
Typing V repeatedly will then cycle through however many voices you have.

Select the music you need to shift into upstem voice 1, right-click, and from the context menu there you should be able to Change Voice to upstem voice 1.
Then do the same for downstem voices and make them downstem voice 1.

Unused voices will get removed from the file automatically, but only when you close Dorico (the program) and reopen it again.

Thanks a lot to all of you, guys!! :smiley: :smiley: :smiley: :wink: :wink:

There’s one last question,

how can I let DORICO “forget” my superfluous voices and -thus- save my work up to now?

Or do I have to restart from the very beginning?

Switch the existing music into Upstem voice 1 and Downstem Voice 1. “Select All” and “Edit > Filter > Filter all Downstem (or upstem) Voices” should make this process really quick.

Unused voices will get removed from the file automatically, but only when you close Dorico (the program) and reopen it again.