Problem Triggering Macros with Midi

Hi-

I’m having a strange issue. I’ve created several macros that recall cycle markers then play those cycle markers.

The macro would be:

Recall Cycle Marker X
To Cycle Marker X
Start

The first Macro recalls macro cycle 1, which plays the loops the track from 0:00 to 10:00.
The second macro recalls cycle marker 2 which plays say 20:00 to 25:00.
The third macro plays a cycle marker further down etc…

When selecting the macros via the edit menu, they work fine. I can bounce between the macros no issue.

When I trigger the macros via Midi the first macro triggers fine. The second macro triggers, then about .25 seconds later it pops back to macro 1. The same on subsequent macros.

I can delete Macro 1, and Macro 2 behaves normally.

It’s as if the triggering of macros 2 onward result in the first macro being played back, even though only the midi note for Macro, 2 or 3 is being sent.

Since the macros behave normally by triggering them via the edit menu, i don’t think it’s the macro. This seems like a bug.

Any thoughts on this would be most appreciated :slight_smile:.

Cheers
Matt

I cant help you ,but i can say that the MAcros and KCs, in Nunedo have been broken for years - ;-(
I use tons of Macros & Kcs with 3 XKEYS and they are not solid . .double triggering, Not triggering, losing window focus . .and using MIdi MAcros are worse . .sorry to say.

but not many users try these so the bugs dont come out IMHO .

I don’t know what this particular problem is, but when using KC that use modifies such as Alt/Ctrl/Shift, Nuendo is too slow to recognise them in many cases. Is it possible to put pauses into your macro? This might fix it.

I was hoping to use my Lemur to trigger KC, but as there is no option to put pauses in the Jazzmutant software, and Nuendo is too slow to recognise the KC, I had to give up on all but the simple KC. However, in your case the pauses might solve your issues.

DG

Actually it seems to be a problem with the “Recall Cycle Command”.

It even does this not as a macro but as a straight command in the device setup window (in my case a generic remote).

If you have 3 cycle markers, when you use Recall Cycle Command 3 it selects cycle 3, then about .25 seconds later goes and selects cycle 1. Any thoughts?

Thanks
Matt

Actually I think it is some weirdness with my midi controller…

I think, it isn’t not your Midi Controller. Had same probs. With KC my Macros run fine, with Midi Controller not.
Have my Midi Controller signals verify with Pugin “Midimonitor” (part of Nuendo), all values was ok, but my Macro dosn’t run proberly. In the end, I have changed my macros with other commands …

( http://www.steinberg.net/forum/viewtopic.php?f=76&t=13155&p=84923#p84923 )

Sometimes Macro’s are executed too fast, so the computer of whatever “can not follow”.
A “pauze” function would solve many problems.
The solution is to program a “useless” function (like zoom in, zoom out) inbetween the steps, so the execution of the macro is slowed down by a harmless intermediate function.

Fredo