Problem when trying to update!


I just tried to update The Grand 3 to the latest ver. but each time I try, it returns an error (see attached jpg) and I already downloaded twice the update file thinking that maybe the first download was corrupted and also, I repaired the original Grand 3 installation but to no avail!

Here is the error text translation since the image is in Spanish:

" The installer found an unexpected error when trying to install this package. This may indicate a problem with this package. The error code is 2254"

Thanks a lot

I have the same problem. I was wondering if you got it fixed.
Thank you,


The official installer that is on the website for download as the very latest, is Ver. 3.1.0 with a release date of 24/01/2011, BUT this is wrong!!! because the very, very latest is Ver. 3.1.1 with the following release date: 08/02/2011
so just go to the following address and download the correct ver:

It seems that Steinberg NEVER noticed their error and it also seems that either, nobody is buying this product, or people do not care about updating it, so go figure :unamused:

Thank you so much. It works like a charm. I guess people are missing out on a great VST.
Happy holidays! :stuck_out_tongue:

I just came across this posting so sorry for this late reply! The Grand 3.1.1 is only needed for Japanese systems and thus is only actively used on our Japanese website. In general, we have several other files on the FTP that are not used on as the are only needed for specific markets.

So how come that we were NOT able to use your regular 3.1.0 installer (error 2254) and the only way to update was to install the 3.1.1?
BTW it is working great and it is NOT the Japanese ver.

Frankly, I don’t know as nothing in this regards has been changed. It is good to know that it worked for you though!

I’ve bought The Grand 3 (the box came with the 3.0.0 version).

The 3.1.0. update install doesn’t work (it says the famous “2254 Error”).

The 3.1.1 that you’ve said, from FPT server, doesn’t work either (it says “cannot install it, you have already a newer version”)… but isn’t true! Officialy The Grand 3 software indicates I have the 3.0.0 version.

It’s frustrating, what can I do?

Regards. Thank you.