Problem with Add Instrument Track

I’ve recently upgraded from Cubase 3 to 5 (on Windows 7 64 bit) and I’m having a bit of a problem. I thought the idea of adding an instrument track was to be able to select a sound rather than an instrument. However when I browse, the only instrument available is Halion Sonic. None of the bundled instruments (e.g. Embracer) are available and are greyed out.

They are available through Media Bay but I can’t figure out why they’re not in the Add Instrument window.

I’m sure it’s something simple but I can’t find anything in the manual or on the forum. Can anybody help please?

I’ve attached a screenshot if it helps.

Thank you for your time.
AddIns.JPG

Aloha Pete,
I always thought the idea of an ‘Instrument Track’ was to
1-load an instrument (Halion., GAO etc) then
2-load a sound into that instrument (trombone, snare etc) then
3-that loaded instrument plays the sound using MIDI info.

Maybe I have this all wrong. I hope not:)


HTH
{’-’}

Yes I thought that was one option, but I thought you could also filter on the sounds, load up the one you want and the instrument that the sound belongs to is loaded automatically? If that’s not the case, why are all the instruments shown but only Halion Sonic is available?

I haven’t upgraded to 5.5 yet, so this window is somewhat alien to me, but if it functions similarly to other browser windows, you may have to remove HALion Sonic from focus to see other VSTi options. Try clicking on the HALion Sonic label (on the far right) to change the focus of the browser.

Routing a VSTi from the VST Instrument Panel to a MIDI channel and creating an instrument track are essentially the same thing. The two do not have different intended musical applications. The main difference between them is routing options. If you plan on using a VSTi through several different outputs (e.g., send multiple samples from Groove Agent ONE to their own individual channels for processing), then loading the instrument in the Instrument Panel will make the most sense. Otherwise, if you only intend to use one output, an instrument track will do. I personally prefer instrument tracks, because they use fewer lanes than their alternative, so I’ll use them whenever possible.

I tried clicking on the far right but it made no difference. So I tried displaying the ‘Location Tree’ and deselecting then reselcting one of the instruments and that made no difference either. So I’ve now made matters worse by deselecting and reselecting Halion Sonic. Now that one is greyed out too!

So now when I add an instrument track and select Browse, everythig is greyed out! Oh dear. I think I may put in a support request.

Yeah, I don’t like Cubase’s browser system very much, especially when it gets in its own way like this. Try clicking on the “Browse” button at the top, and see if that makes a difference.