Problem with adding vst instruments in Dorico 5

Dorico staff, first of all my compliments for your super update again, really awesome!
I have a problem adding my vst instruments, the window no longer shows the option to add or remove vst…
Is there a solution for this?


MacBook Pro M1 Max
Mac osx Monterey
(16-inch, 2021)

On Apple Silicon we don’t support VST2 plug-ins anymore. If you still want to use them you have to start Dorico in Rosetta mode.

1 Like

Hi Ulf,
Don’t support vat Anymore? i mean, apple silicone just came out and you guys are canceling vsts support?… okay, maybe it’s not that bad, what about the AU then? I hope not the same because I have thousands of euros in plug-in tools that I really want to use.
Rosetta is maybe possible, but the functionalities are always less than in native mode. I noticed that with Logic Pro….

We have no current plans to support Audio Unit plug-ins, but you can run VST3 plug-ins natively in Apple Silicon. If you want to run VST2.x plug-ins, you need to run Dorico under Rosetta. This is all the same as in Dorico 4.

1 Like

Hi Daniel,
thank you and nice to hear about the vst3, but as you can see in my image i can’t add or remove anything.
All my plugins are vst3 (eg the toontrack instruments), but I don’t see them in native mode. look at the picture that’s what i see.

The question really is, are all your VST3 plug-ins already compiled as universal binaries for both intel and ARM architecture? I bet a fortune that all the ones you are missing are not yet native Apple Silicon compatible.

wow what a difficult question Ulf.
I’m going to check it out, but it seems to me since many have been recently updated

this is what i found (see below), but it looks like it should work.
but again my question, why don’t I see in Dorico “preferenses/vstPlug-ins” not the 2 windows where you can add or remove plugins?..

Toontrack’s software has been updated to work on the latest macOS Monterey as well as Windows 11. It works on both Intel and Apple silicon systems as well as with all major music software/DAW applications, such as Pro Tools, Cubase, GarageBand, Logic Pro, Reaper, etc. EZdrummer 3 can also be run standalone.

As Ulf has said, Dorico doesn’t show those controls when you’re running natively on an Apple Silicon Mac because VST2 plug-ins cannot be run natively on an Apple Silicon Mac. You don’t need these controls for VST3 plug-ins because they all live in a fixed location on your computer, so you don’t need to tell Dorico where to find them, indeed you cannot tell Dorico where to find them: it knows where to find them already.

I wonder whether the problem is simply that you need to scroll the menu in the rack? When you show the menu to load a plug-in in the VST & MIDI panel in Play mode, try dragging the menu upwards to reveal any manufacturers that are off the bottom of the menu.

1 Like

You don’t see that dialog for adding or removing plug-ins because that is only for VST2 plugs and because they are not supported any more on apple silicon that part is blended out. VST 3 plugs are always recognized by Dorico unless the vstscanners put them on the blacklist for whatever reason. If you are sending me a diagnostics report I can tell you the reason.

1 Like

thank you both…
Daniel I checked if indeed it was a stupid scroll problem from me, but no unfortunately not, I can’t continue scrolling (see picture)

I also took another look, but the toontrack vst3 instruments support apple silicone machines

Please do Help > Create Diagnostic Report and attach the resulting zip file so we can see whether the logs show what might be happening with those plug-ins.

post here or send private? I don’t know if it contains important information

You can do either, as you wish. There’s nothing particularly sensitive in the diagnostic zip file – you can take a look inside to reassure yourself what data is being created.

Dorico (1.8 MB)

I think we need @Ulf to weigh in, but to my semi-trained eye, it looks as if the Toontrack plug-ins are indeed being rejected on the grounds that they’re the Intel versions, and so they won’t run unless Dorico is running under Rosetta.

(I’m basing that on what’s in the vst3blacklist.xml file.)

uh okay, let’s see what Ulf says.
I think it’s strange because one came out last week.

this is what i found…

System Requirements

  • MacOS 10.10 Yosemite and above
  • Windows 7 and above (64-bit only)
  • Intel, AMD, or Apple Silicon CPU
  • 4GB RAM or more (8GB or more recommended)
  • 5GB free storage space

Plugin Formats

AAX Native, AU, VST2, VST3, and Standalone (64-bit only)

i found it here

I tried using Toontrack plugins (vst 3), viz., EZKeys, EzBass and EzDrums, all the latest versions of the plugins, and they all worked on Dorico 5 Pro. Ofcourse the Ex-Map for EzBass and Perc-Maps for EzDrums need to be made (for trial I used “Transform up 1 Octave” Ex-Map and “GMMidi”/ “Yamaha XG” Perc-Maps. For correct playback of articulation/ sounds, these maps will need to be modified to suit the Keyswitch Layout (Ez Bass) or Midi-mapping layout (EzDrums). EzKeys I just used the default Ex-Maps.
Hope this feedback helps.

Hi Ravindran, thx for your help.
Are you using them in rosetta mode or in native mode? because in Rosetta I see them, but in native mode they are not recognized by me…