Problem with complex time signatures

Hi everyone,

I have a problem with complex time signatures. I’m using Dorico 2.2.1.

I have a piece that is constantly switching between 3+3+2+2/8 and 3+2+2+2/8.
I used the alternative time signature, which is working fine (screenshot 1, first system)
However, I would like a dotted bar lines between the first and the second bar of each group of two bars.
That’s why I switched to the aggregate function. The thing is, in this mode, we must keep the default beat grouping. When I try to change it, it goes back to the alternative time signature mode, and the dotted barlines disaeppear at the same time (screenshot 1, second system)
Then, I came back to the alternative time signature function and put the dotted barlines manually. Then, everything is working fine. (screenshot 1, third system)

However, each time I close my file and I reopen it, there is a bug, the first two bars become in 10/8, and everything is shifted after. Each time I open the file, I need to go back to the time signature, erase it and create it again (screenshot 2, third system). Does anybody have an idea where this bug comes from?

Here is the Dorico File : https://we.tl/t-EGctfwC7yg


Hi francisb

I’m not sure if that is what you want, anyway i would suggest the following:
An Aggregate time signature from the first bar, invoke the time signature popover and type [3+3+2+2]/8|[3+2+2+2]/8
(Delete the other time signatures).

Rafael

Hi Rafael,

It works perfectly, thank you so much!

Well I think aggregated time signatures are not want I want actually, because the accidentals now are effective during two bars instead of one…
I would prefer alternated time signatures with dotted barlines which I can put manually, but the bug is persistent…

How are you creating/changing the dashed Barlines?
whit the right panel?
with the popover?
copying with alt+click? (after creating one of course)
maybe alt+click ist the quickest way, but i have experienced that you have to click right after the Barline you want to change, if you click exactly over the Barline the new Barline is created before in the Rythmic grid and that change the rythmic content of the bar. Could that be your case?

The dashed line is not intended to act as a bar line but as a rhythmic guide within the composite measure. Thus the dashed bar line does not cancel accidentals. For now at least, if one does not like this, one will have to add the repeated accidentals manually or choose an accidental option that repeats them within the measure.

I’m creating the dashed barlines on empty bars with the popover. Then, I copy these bars several times. It is quite fast because I can copy large groups of bars at once.

I agree the dashed barlines in composite measures should not cancel the accidentals.

The problem, I think, is that dashed barlines that are put manually interfere badly with alternating time signatures. It creates a bug that I need to fix manually each time I open my file. It would be cool if a member a of the development team see this message so the bug could be reported…

For now, I decided to drop the dashed barlines and keep only regular barlines with alternating time signatures. Adding all the accidentals I need with aggregating time signatures would be too long.

Thanks for your help :slight_smile:

If somebody from the development team doesn’t respond quickly it normally means that a) they’re all pushing towards a deadline or b) it’s a particularly tricky problem that they want to investigate before they can give advice. The good news is that someone from the development team will chime in when they’ve had a chance to look at it; you may just need to be patient.

Hi pianoleo,

That’s great! I noticed how the team is very committed to the community and the proper functioning of their software. That’s one of the reasons why I quit Sibelius.

Just following up on this thread: we have reproduced this problem in-house and we’ll do our best to fix it in a future version.