Problem with correct length values of rests

Dorico has changed a quarter note rest to a whole note rest and doesn’t allow me to change it back.
This happened when I opened a work I’ve been working on and previously it was correctPicture1


I can change the whole rest to a quarter note but not to a quarter rest.
If I change this rest to a quarter note and then delete the quarter note it goes back to a whole rest.
This is the first bar of a piece and the time signature is open.
Any idea why this is happening?

It would be easier to diagnose if you attach the project rather than a picture, but you should be able to create an explicit rest of the appropriate duration: start note input at that point, hit O to engage Force Duration, hit , (comma) to engage rest mode, type 6 to choose quarter note/crotchet duration, then hit Y to input the rest.

Thanks Daniel.
Have tried this several times but not working.
Works in other staves but not this one.
Project attached.Installation demo snare drum.dorico (782.6 KB)

In this specific case it’s because your snare drum is inside a kit, and you cannot currently edit the rests in music for percussion kits (though this is something we will certainly change in future versions). For now, you can simply remove the snare drum from the kit, because if you only have a single instrument in the kit, it really doesn’t need to be in a kit. Rests on regular percussion staves outside of kits can be edited in the normal way.

Thanks Daniel.
This worked perfectly. I was experimenting with a kit earlier and didn’t erase/clear it properly when I decided not to use it.