Problem with grace notes at the beginning of system

I’m not sure what to do about this. I have a piece I’m engraving, and it has some grace notes that occur at the beginning of a line. I put the grace notes in, create a system break, but the grace notes disappear and the slur is back on the previous line. I can select the slur and put in another system break, but the next time I move out of engrave mode, it reverts. The entire piece is senza misura, so there’s not an issue with whether the notes are set to before or after the bar lines. I’ve included pictures below.

What I have in write mode.
Screen Shot 2021-04-10 at 20.09.44

What occurs:

What I need:

I don’t believe that this is a bug, but I am at a loss to figure out what I’ve done wrong.


It may help to insert a dashed bar line and then go into engrave mode and set the property to after bar line and then in the engraving options set the length of the dashes for a dashed bar line to be zero and the bar line will disappear but then you will still have the normal anchor points and Dorico will think that there is a bar line there, so that way when you enable the grace note properties, everything should render correctly.

Thanks for the suggestion of the dashed barline. It fixed the issue with the grace notes. The only problem is that earlier there are some dashed barlines in the piece, so if I change this one, they all change. But, I did select a tick mark there and I can live with that, at least for now. Thanks for the help.


I don’t get the same result with a cursory “test” - can you share a cut-down version of the project with just this bit in (or however much you’re comfortable sharing)? Was this a project that started in Dorico or was it an XML import? If you import this flow into a fresh project, does the issue still occur?

Hi Lillie,
I’m putting up most of the movement with the other flows removed. I even removed some of the movement here. But the problem is still there. I could not recreate this by exporting, so i assume it’s an issue in the file, maybe a setting, but I haven’t been able to figure out what setting. If I have to export all 8 flows (one movement had 3 flows because of how each is laid out on the page), it could take a while to reformat and I’m worried I’ll be back to the same problem.

I thought I had a solution worked out, but when I reopened the file, it had not actually worked.
Thank for looking at this.

My problem file.dorico (487.1 KB)

A very quick play around here suggests it’s the fact that your “Piu mosso” tempo mark was attached to the grace note position, rather than the full beat (on the C#). Moving it to there seemed to fix the grace note split issue, at least. Attaching items to grace note positions rather than “full” positions can cause little issues, like excess spacing if the tempo mark is long. If needed, you can offset the tempo mark in Engrave mode to create the same visual effect.

Thanks, Lillie. That seems to have done it! I think I had accidentally moved it in Write mode instead of Engrave, so it attached to the grace notes.

BTW, I loved the interview on Scoring Notes this week.


1 Like

Glad it’s sorted :slight_smile: and thank you very much!