Problem with installation Cubase 6 for Mac Catalina

Hi, I have this problem, I bought Cubase 6 and I cannot install it, I have the installer on the DVD and I get a message that I need an earlier version on MAC.
I have MA Catalina 10.15.7.
What can I do in this situation?

I don’t think you will be successful trying to install v6 of Cubase on a later version of OSX like Catalina. Think about it— there is no way Steinberg could have tested their Cubase build from almost a decade before on that OSX. I still run Cubase LE 6 on High Sierra but it is a bit flaky. Apple are not good with backward compatibility either so if Cubase is paramount to you install the last recommended version of Mac OSX and use that.

Windows is another thing though — they have backwards compatibility options on install so Cubase 6 will install and run on Windows 10. I lost access to Pro Tools 8 way back in the Mountain Lion days but I can still install it on Windows 10.

thank you for your opinion, it made me very sad :frowning: