problem with instrument change labels

For some reason unknown the score I’m working on started showing the instrument change labels in the first bar, which is ok for percussion, but all the rest of the instruments only play one instrument, so the flute part shows FL. in the first bar etc. I’ve looked for ways to get rid of these but have had no luck. Would like to see them disappear. Thanks.

To turn them off globally, turn off this setting:

To remove individual change labels, a quick and dirty workaround is to select the change label (or Ctrl/Cmd+click multiple change labels), go to Engrave mode. In the properties panel turn the Instrument Changes > Custom Text switch on, then enter a single space into the text box that appears. Click anywhere on screen for the change to take effect.

Thanks pianoleo, I’d swear I tried that and nothing happened, but this time it worked.