Problem with irregular bars at start/end of flows

I’ve come up against a strange problem with a project containing two flows. The file is in Dropbox here:




There is an irregular (half) bar at the end of flow 1, and at the start of flow 2. Although the score and most of the parts look OK, you’ll see in Part 2 which has no music at the end of flow 1/start of 2, the dotted minim rest has disappeared at the start of flow 2, and the spacing of the bar looks odd. I can’t see anything I may have inadvertently added/deleted to do this.

Also, the half bar at the end of flow 1 is represented in the parts by a single bar multirest, which is misleading - I can live with this for now but would like to know if there’s a way round it (switch off multirests on an individual basis? I’ve looked for a way to do this but can’t find it).

Finally, I have been playing around with allowing flows on the same page rather than starting a new page, and I keep finding that the half bar at the end of flow 1 has somehow been converted into a whole bar.

[EDIT: This appears to happen when I open the file]

Any help with any of the above much appreciated. Thanks!

The start of flow 2 fixed itself when I removed the time signatures and then, at the start, entered [3+3]/4,3

You can switch multibar rests on and off individually for each player in Layout Options/Players, but I’m not sure I follow what you mean by half bar at the end of flow 1. Even if you changed the time sign. to 2/4 it would still be correct to show this as a bar rest if the time sign is visible…

Sorry, I didn’t make that clear - there should be half a cut-common time bar (i.e. the same as at the beginning) at the end of Flow 1. The program for some reason keeps changing it to a whole bar (in the score as well as the parts) when I open the file. Even when I fix it by inserting a barline and then trimming the flow, the parts still show the half bar as a whole bar multirest. This can’t be correct surely?

I have followed your suggestion re. Flow 2 and that worked, so thanks for that. I wasn’t aware I could enter anacrusis bars like that. Useful!

Following this new bit of wisdom and having read the popovers PDF I have also tried entering cutc,2 at the start of the final half bar and then hiding the time signature, which produces a bar of the correct length in the score, and seems to have fixed the problem of the bar length changing on opening the file, but still shows the half bar in the parts as a single bar multirest.