Problem with lyrics

Suddenly I got a problem with Lyrics. Some bars are adjusted automatically, but some Bars appear wrong. Some words overlap. I enter the lyrics by copying and inserting the text using Ctrl+V. I enter the lyrics often but this problem has never appeared. How can I edit it?
Thanks!
Miroslav

We’ll need a little more info than that. If not a project file, at least a screenshot.

How can I attach the screenshot? There is not some icon.

Screenshot:

Turn on signposts, please.

Do you have fixed casting off set?


What is “casting off”?

what happens, if you remove those System Breaks?

1 Like

When I delete System Breaks:
Screenshot
When I click “Reset Layout” nothing happens…

I’m sorry, I’ll continue tomorrow. Thank you

If you’re going to delete system breaks, you need to delete all of them: the one at the beginning of the third system clearly has the Wait for next system break property activated, which is why all those bars are forced onto the system. You could try using the new Unlock Layout feature in Engrave mode to remove all of the breaks in one operation.

Your systems are too full, from the looks of it, and if I had to guess, you’ve also manually adjusted note spacing at least once or twice. Removing those overrides (both system breaks and manual spacing) should allow dorico more freedom to lay things out in a more satisfactory way.

2 Likes

Thank you for your advice. It hasn’t helped me yet. I tried to undo all edits and start over, but the result is the same. But somehow I’ll deal with it …

Check whether Layout Options has a fixed number of bars per system.

If you can provide the project file, either here, or privately to anoyne who’s contributed here, I’m sure they will be able to point out what’s going on.

Hallo,

If you want to help me, I’m sending Project.
Miroslav

---------- Původní e-mail ----------

Od: benwiggy via Steinberg Forums notifications@steinberg.discoursemail.com

Komu: hanoj2@seznam.cz

Předmět: [Steinberg Forums] [Dorico] Problem with lyrics

MIT 66 JAHREN.dorico (2.67 MB)

Hello,
Why don’t you delete all system break as people say?

Dorico has a clever algorythm to space music and for a lot of things
best regards

1 Like

You had hidden all the Signposts. You still had System Breaks on every line.

Screenshot

Also, if you turn on Tempo signposts, you’ll see you’ve got hundreds of entirely unnecessary tempo edits . You should delete all of those.

Here is a revised file.

MIT 66 JAHREN.dorico (1.4 MB)

2 Likes

To benwiggy:
Thanks for help. Now is it solved.

The reason that these tempo events end up influencing spacing is due to a limitation in the way Dorico’s spacing works. Its horizontal collision avoidance capabilities rely on the columns that need to be resolved being rhythmically next to each other. (It’s a bit more complicated than that with things like dynamics etc. that span multiple columns outside the staff, but this is a nice simplification for the purposes of this explanation.)

Any item that is at a rhythmic position where there is otherwise no note on any staff nevertheless causes a spacing column to be created. If you have one of these empty columns between two notes with lyrics, then the first lyric is not spaced against the lyric on the following note, but rather against the empty column between the first and second notes; likewise, the empty column then spaces itself against the lyric on the following note, and because it has no lyric of its own, Dorico thinks the following lyric doesn’t collide with anything, and hence just gives both columns with lyrics their default width. Effectively, then, it is as if the lyrics have no width in that situation.

This is a limitation that we do want to address, but it’s not a small job and of course it has the potential to cause the appearance of existing projects to change a lot (because there will be situations where users have corrected for this limitation, and those offsets would then end up getting applied to a different result after Dorico can handle it more effectively). Another refinement would be to ensure that an item that ends up completely hidden, like these tempo items, don’t cause columns to be created at all (though if you have e.g. a Shift+X text item at a rhythmic position between two notes the same problem will apply, so we still need to address the more fundamental limitation).

In short, then: this arises from a limitation in Dorico’s horizontal spacing capabilities that we plan to address in a future version.

7 Likes