Problem with Mackie Controller Pro

I had no problem with Cubase 5 and XP, but I cannot get it to work fully in Windows 7 64 bit. The Mackie though works with Samplitude 10 in Windows 7. It seems to be an Cubase issue. On XP, there was USB drivers to choose from. Now the USB driver is called MCPU Pro USB and midi n2 CMCUP10 USB.30 for my Mackie Expander.

I would appreciate if Steinberg would look further into this issue.

Not sure that I’ve a good understanding of the issue but AFAIK the MCU Pro and MCU Ext Pro are “class compliant” plug ‘n’ play devices that do not require any USB device drivers to work.


With the Mackie Controller Pro, you can choose midi into your computer, or USB port. I had been using the USB port on XP and it worked fine with Cubase and Samplitude. Once I went to Windows 7 64 bit, the USB connector did not work properly with either DAW. Someone on the fourms suggested I try the midi connectors instead. I tried it with Cubase and both my Mackie controller Pro and Expander work fine now.

No issue with MCU Pro USB port and Win7 x64 here.


I noticed you have Cubase 6. Does it work in Cubase 5 as well which is what I am running? By the way I got it working with the USB about 25 percent of the time. I went back to the same template later and it did not work.

I can’t answer as my MCU Pro and MCU Extender Pro are connected to my Nuendo 5 DAWs only (PC A or PC B).
Cubase DAW (PC C) is slaved to Nuendo using VST System Link and doesn’t have any control surface.
However I don’t see any reason why this should not work as expected.
MCU Pro is a very common interface used by a lot of Cubase/Nuendo users over here.

Have you try to use another USB port on your PC ?
Are you running any USB Hub ?


I have the same problem also. On the two extenders I get …U…N…S… on the screens. The faders move but there is no graphical information. The main MCU Pro shows the track infomation on the screen, but the play, pause, stop etc doesn’t work.
Everything worked fine before I upgraded to Cubase 6.

I work with these all day, so this is a nightmare!


I have MCU Pro and extender which worked fine on Cubase 5. There are some problems on Cubase6 64bit, Im running verse 6.0.0.

I have good reasons not to upgrade just now but can anyone tell me if there was a fix for the MCU pro/extender problems in the latter Cubase 6 updates?